Question RTX 2080 Rendering/Graphic Issue

Sep 9, 2019
1
0
10
0
Recently got a new RTX 2080 and i've been having a consistent issue across all of the games that I play.
I'm getting this Pixelated/Grid pattern that seems to render over any transparent objects or objects that fade out of sight. This is an issue i've been having in GTA5, Control, and most noticeably in XCOM 2.

The screenshot below from XCOM 2 shows the pixelation on the character's helmet visor.
View: https://imgur.com/a/bSMBbma


And this screenshot shows the pixelation on the character's fur mantle.
View: https://imgur.com/a/JYgtK3E


I was recently playing these games on a previous build with a GTX 1070 and this was not an issue for me until I upgraded to an RTX 2080

The troubleshooting that i've tried goes as follows:

-Uninstalled and rolled back to previous Nvidia Drivers as well as updated bios and chipset
-Updated Windows 10
-Tried a different HDMI Cable
-Tried a different monitor

System Hardware:

Intel i5 9600k
RTX 2080
Crucial Ballistix Sport ddr4 x2 8gb
Asus Prime Z390-A

I'm not really sure what else I can try at this point. If this is a defect with my GPU then i'm still within the RMA time frame.
 
Sep 9, 2019
1
0
10
0
Recently got a new RTX 2080 and i've been having a consistent issue across all of the games that I play.
I'm getting this Pixelated/Grid pattern that seems to render over any transparent objects or objects that fade out of sight. This is an issue i've been having in GTA5, Control, and most noticeably in XCOM 2.

The screenshot below from XCOM 2 shows the pixelation on the character's helmet visor.
View: https://imgur.com/a/bSMBbma


And this screenshot shows the pixelation on the character's fur mantle.
View: https://imgur.com/a/JYgtK3E


I was recently playing these games on a previous build with a GTX 1070 and this was not an issue for me until I upgraded to an RTX 2080

The troubleshooting that i've tried goes as follows:

-Uninstalled and rolled back to previous Nvidia Drivers as well as updated bios and chipset
-Updated Windows 10
-Tried a different HDMI Cable
-Tried a different monitor

System Hardware:

Intel i5 9600k
RTX 2080
Crucial Ballistix Sport ddr4 x2 8gb
Asus Prime Z390-A

I'm not really sure what else I can try at this point. If this is a defect with my GPU then i'm still within the RMA time frame.
I'm having the exact same issues, It seems really bad with RTX on. I'm having this issue with multiple games.

Gigabyte RTX 2080
AMD 2700x
G.Skill DDR4 x2 8gb


These images do not really do the problem justice, it looks a lot worse in motion.
Screenshots taken in DX12. It seem it get better in DX11 mode.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS