[SOLVED] RTX 3050 keeps freezing PC ?

Status
Not open for further replies.
Feb 27, 2022
6
2
15
0
I have had for about 2 weeks the ZOTAC GAMING GeForce RTX 3050 Twin Edge and from this time i have a random pc freeze and restart .The Gpu works perfect in games,under heavy load, stress test, 3d rendering, but when i browsing or doing any light work, out of nowhere the pc randomly freezes and restarts, or stays frozen until I press the restart button.
I see that people start report this issue. I make all steps to solve the problem but nothing.
 
Reactions: Quoc Dung

dcvikes

Distinguished
Dec 27, 2007
65
4
18,565
14
It's very likely a power handling issue within the nvidia drivers I have seen this issue reported across various forums including Reddit - and as of yet have not built a machine using that card but I would suspect that nvidia will offer a driver fix eventually. Desktop power settings are more CPU based this sounds like purely a GPU driver issue with lower clock rate-handling. For some that may not know here is where you toggle max performance in the nvidia control panel.

 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

We're going to need a little more information from your end. When posting a thread of troubleshooting nature, it's customary to include your full system's specs. Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:

Include the age of the PSU apart from it's make and model. If the discrete GPU stated above was an upgrade, mention what you were using prior to the GTX3050.
 
Feb 27, 2022
6
2
15
0
CPU : 5600x
Motherboard: gigabyte B550 AORUS PRO V2
Ram: Corsair Vengeance RGB Pro TUF Gaming 32GB
SSD/HDD: Samsung SSD 970 evo plus 1TB
GPU:ZOTAC GAMING GeForce RTX 3050 Twin Edge OC
PSU: corsair RM750x
Chassis: Corsair Icue 220T
OS: Windows 10 Updated
Monitor: Samsung LU28R550 4k
All the setup is 6 months old include GPU MSI 1050Ti and all this time PC works perfect
From the day (3 weeks from now) that i replace with RTX 3050 start the problem
 

Quoc Dung

Distinguished
Apr 1, 2015
11
0
18,510
0
Do you have BIOS updated as well?

Funny fact that this is the same excat issue I got after I installed my ASUS ROG STRIX RTX 3050 GAMING OC. Never had issues with older cards GTX 1050 TI and GTX 1650 super on my same hardware
 
Feb 27, 2022
6
2
15
0
I already done all the thinks you can do
reset cmos bios, Format pc ,update BIOS ,put the GPU to other PC and make the same issue after one day, memtest86 4 Passes ,SSD check ,furmark test, cinebench
When i use my old GPU everything work perfect so i know that is GPU issue.
The weird think is that the freezing come always to me only in light load (not on furmark test or gaming) always when GPU power is in Low Watt and the GPU clock and memory clock at low MHZ
 
Reactions: Quoc Dung

Quoc Dung

Distinguished
Apr 1, 2015
11
0
18,510
0
I already done all the thinks you can do
reset cmos bios, Format pc ,update BIOS ,put the GPU to other PC and make the same issue after one day, memtest86 4 Passes ,SSD check ,furmark test, cinebench
When i use my old GPU everything work perfect so i know that is GPU issue.
The weird think is that the freezing come always to me only in light load (not on furmark test or gaming) always when GPU power is in Low Watt and the GPU clock and memory clock at low MHZ
That's what i thought too. I have set it to performance mode in nvidia control panel to keep clocks at max, see if it solves the issue
 
May 21, 2021
126
65
170
5
I already done all the thinks you can do
reset cmos bios, Format pc ,update BIOS ,put the GPU to other PC and make the same issue after one day, memtest86 4 Passes ,SSD check ,furmark test, cinebench
When i use my old GPU everything work perfect so i know that is GPU issue.
The weird think is that the freezing come always to me only in light load (not on furmark test or gaming) always when GPU power is in Low Watt and the GPU clock and memory clock at low MHZ
That is very strange….do me a favor and test this out for me. Go to “settings” from the start menu, click on “system”, then click on “power and sleep”, under related settings click on “additional power settings”, then enable the “high performance” power plan. It might be hidden away under “show additional plans” if you don’t see it right away under “preferred plans”.
That should disable any pci-express power saving features for your GPU from the windows side. If that doesn’t help I’ll walk you through how to use nvidia settings menu to try disabling power saving features.
Oh and btw, this is not a fix unless you are okay with your graphics card consuming more power under idle or low load. This is to get more evidence in order to make a thorough diagnosis. Hope this helps
 
Feb 27, 2022
6
2
15
0
Thanks yes i think i try this in the first week and didn't help but i give it again a try.
I think is the GPU don't work well under low watt and clock MHZ. How may days you have performance mode ?
 

Quoc Dung

Distinguished
Apr 1, 2015
11
0
18,510
0
That is very strange….do me a favor and test this out for me. Go to “settings” from the start menu, click on “system”, then click on “power and sleep”, under related settings click on “additional power settings”, then enable the “high performance” power plan. It might be hidden away under “show additional plans” if you don’t see it right away under “preferred plans”.
That should disable any pci-express power saving features for your GPU from the windows side. If that doesn’t help I’ll walk you through how to use nvidia settings menu to try disabling power saving features.
Oh and btw, this is not a fix unless you are okay with your graphics card consuming more power under idle or low load. This is to get more evidence in order to make a thorough diagnosis. Hope this helps
Wouldn't this settings make CPU clock max too?
I'm ok with higher power consumption on my GPU while my electricity bill has incresed a lot this year
 

Phillip Corcoran

Titan
Moderator
my pc has been having lots of problems with my PC (Legion T5-28IMB05 Desktop (Lenovo) - Type 90NC) I was having DPC watch dogs errors but I did a full reset to my computer rolled back to multiple drivers and I made the proper power plan changes I haven't had the DPC watchdog error but now the same freezing and restarting happens but with new errors
It's customary to start your own thread when you need help, not "hijack" an existing thread started by someone else.
Threads can get very messy and confusing otherwise. So please start your own thread.
 
Mar 1, 2022
2
1
10
0
I had the same issue. RTX 3050, the latest driver, even I've replaced with a new card, new motherboard, new psu, reinstall windows, the same issue still encountered.
Sometimes it freezes, after few seconds, it can be recovered.
Sometimes it just freezes, but windows still running(I heard the discord notification and music while PC freezing)
Sometimes it freezes then reboot, just like BSOD.
 

BConATL

Honorable
Jan 25, 2016
3
0
10,520
1
I have the same problem with my EVGA RTX 3050 XC. Gaming's fine, but when browsing the web, Windows Explorer can crash and reset, or my PC can just lock up. I've narrowed it down to Google Chrome, as it only happens when using it. Other browsers are fine. The frequency of the crashes is less after disabling hardware acceleration in Chrome, but they're definitely not gone. It also helps to close Chrome every so often and restart. All of this makes me think that it's a driver issue. I submitted a report to NVIDIA detailing the issue, but haven't seen them acknowledge the issue yet.
 

dcvikes

Distinguished
Dec 27, 2007
65
4
18,565
14
It's very likely a power handling issue within the nvidia drivers I have seen this issue reported across various forums including Reddit - and as of yet have not built a machine using that card but I would suspect that nvidia will offer a driver fix eventually. Desktop power settings are more CPU based this sounds like purely a GPU driver issue with lower clock rate-handling. For some that may not know here is where you toggle max performance in the nvidia control panel.

 

Quoc Dung

Distinguished
Apr 1, 2015
11
0
18,510
0
Plaese tell me how many days you set it to performance mode and if with this setting you have the issue ?
just 1 day now, no issues so far. i'll report after few days

There are more posts regarding this issue

Code:
https://www.reddit.com/r/buildapc/comments/t0l5ux/anyone_else_having_issues_with_their_rtx_3050/

forums.evga.com/RTX-3050-Random-Freezes-and-black-or-blue-screens-m3525909.aspx

https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/486777/my-awful-experience-with-the-zotac-gaming-geforce-/

https://www.nvidia.com/en-us/geforce/forums/geforce-graphics-cards/5/486962/rtx-3050-freezing-issue/
 
May 21, 2021
126
65
170
5
It's very likely a power handling issue within the nvidia drivers I have seen this issue reported across various forums including Reddit - and as of yet have not built a machine using that card but I would suspect that nvidia will offer a driver fix eventually. Desktop power settings are more CPU based this sounds like purely a GPU driver issue with lower clock rate-handling. For some that may not know here is where you toggle max performance in the nvidia control panel.

Yes this was my next course of action if the windows power plan didn’t work. The reason it was second to the windows power plan is that this setting results in significant idle power usage so isn’t really a good fix unless you need a space heater
 
Reactions: Quoc Dung
Mar 2, 2022
2
1
15
0
I thought I was going mad...

Recently got a MSI RTX 3050 Ventus 2x OC to replace an aging, coil whining 970.

I've had more lockups and bluescreens the last few weeks than in the ~2 years I've had this rig, and google failed to find any mention of it.

Tried several different drivers (grd and studio with DDU inbetween them), BIOS resets, memtest for hours, disabling XMP seemed to work for a few days but it just did it again while going to hover over a link in chrome...

I've changed the PCI link power setting, hoping that fixes it for now as the instability made work almost impossible (and with others saying it's Chrome and at low power, that makes sense why it did it multiple times while working, but almost never during games etc).
 
Reactions: Quoc Dung
Mar 3, 2022
3
1
15
0
Anyone tried to increase minimum clock speed with afterburner or similar instead of running @ maximum ? Problem only on single monitor/display environment? With more than one display minimum clock speed raises automatically?

Add: The option to set minimum clock speed (2D profile) within afterburner isn't supported anymore. Any other solution?
Clock speed stable @ multimonitor these days.
Sadly a retoure - waiting for redesign, maybe next year.
 
Last edited:
Reactions: Quoc Dung
Status
Not open for further replies.

ASK THE COMMUNITY