Question RTX 3080 low fps

Oct 13, 2021
18
1
15
0
Hello,
I just got Hellblade and to my surprise it runs on 40-50 fps, 1440p max settings ray tracing high.
Which is not what other people get with 3080.
Anyone has any idea what causes this?
 
Oct 13, 2021
18
1
15
0
Please post the link to your results instead. Also please list the specs of all the parts in your PC and include each parts exact model.
https://www.userbenchmark.com/UserRun/50164567
For some reason it says GPU benchmark missing? anyways the full specs :

AMD Ryzen 7 5800X AM4
Corsair iCUE H100i RGB PRO XT Liquid CPU Cooler
Asus ROG STRIX B550-F GAMING
Corsair DDR 4 32G (16Gx2) 3600 CL18 Vengeance RGB PRO
Corsair RM750x 750W PSU 80+ Gold
Addlink SSD 1.0TB S72 M.2 2280 NVMe
Gigabyte RTX 3080 Gaming OC 10GB
 
Okay so you need to turn off G-sync or freesync if it is on and make sure you do not have any global framerate limiters on. You have high CPU background usage when you did the test. Restart the computer and turn off any non essential programs and services to retest Userbenchmark and post the results link back here. It shows your SSD as being slower than a disk drive which is very concerning. Were you downloading or installing anything when you did the test?
 
Oct 13, 2021
18
1
15
0
Okay so you need to turn off G-sync or freesync if it is on and make sure you do not have any global framerate limiters on. You have high CPU background usage when you did the test. Restart the computer and turn off any non essential programs and services to retest Userbenchmark and post the results link back here. It shows your SSD as being slower than a disk drive which is very concerning. Were you downloading or installing anything when you did the test?
Yeah I don't know why that is with the SSD.
I had frame limiter set to 140 as my monitor is 144 hz, also had G sync on, turned them both off restarted and here's the benchmark after restart:
https://www.userbenchmark.com/UserRun/50165749

DirectX 11 test was not completed ... by any chance Hellblade running on DX 11? That could mean problem with GPU drivers.
Hellblade is running on DX12
 

Vic 40

Titan
Ambassador
Would update the bios,

BIOS Date20201203

Latest being,

Version 2423 from 021/08/26
Think btw that Userbenchmark has some issues with the gpu related tests. Can't see why your gpu would be the problem there and had something weird when i tried a test too.

Are you btw using both pcie power cables to power the gpu?
 
Last edited:
Oct 13, 2021
18
1
15
0
Would update the bios,

BIOS Date20201203

Latest being,



Think btw that Userbenchmark has some issues with the gpu related tests. Can't see why your gpu would be the problem there and had something weird when i tried a test too.

Are you btw using both pcie power cables to power the gpu?
I will look into the BIOS update, and yes both PCIE power cables.
 
Oct 13, 2021
18
1
15
0
I am now seeing some better performance after changing some settings in the control panel and doing what you told me.
But still not as good as other RTX 3080 owners, It seems to be mostly around 65-85 atm with everything on max including Ray Tracing (Which seems to lower fps almost by half, with it turned off the game runs on 130-140)
But seeing on YouTube, people run this game with max settings on 1440p on 75-100 mostly.
 
Oct 13, 2021
18
1
15
0
Did you already update the bios?
I did now, there is an improvement, running 70-85 mostly , some lows to 65.
But decided to change from Quality DLSS to Balanced, changed some Nvidia control panel settings, and now it runs on 80-100 but rarely drops below 75.
Thanks for the help!
 
Last edited:
Reactions: Vic 40

ASK THE COMMUNITY

TRENDING THREADS