Question RTX 3080 with Ryzen 9 5900x low GPU usage on games

Sep 20, 2022
5
1
15
0
Hi there,
So I've recently assembled a pc with the following specs:
  • AMD Ryzen 9 5900X 3.7GHz (4.8GHz Turbo), 12-Cores 24-Threads, AM4
  • MSI B550M PRO DASH, Chipset B550, AM4, mATX, DDR4
  • Memory DDR4 Geil Potenza, 16GB 3000MHZ, Black (x2)
  • Galax NVIDIA GeForce RTX 3080 SG (1-Click OC), LHR, 12GB, GDDR6X, DLSS, Ray Tracing
  • Super Flower LEGION GX PRO 850W, 80 Plus Gold
And although I've been mostly satisfied with the performance I'm getting, I can't shake the feeling that there might be something wrong with my build. On games like Cyberpunk and Deathloop GPU usage remains low, about 50% in Deathloop on ultra with RT enabled and 80-90% on Cyberpunk ultra RT mode (not as low but still not fully utilizing my GPU as seen in other benchmarks).
Do you guys have any idea what might be causing this? Feel free to ask me for more information as I believe what I've provided will most likely not be enough

P.S: Both Cyberpunk and Deathloop as well as all games listed below were running at 1440p and GPU temperatures are below 80 degrees Celsius at all times
P.S 2: I've checked and my graphics card is in a PCIe 4.0 x16 slot, so I've discarded this possibility as well

Things I've tried:
  • Setting windows power mode to best performance
Possible causes?
  • I'm aware my motherboard does not support XMP, could this be the issue?
Here are a few more games I tested and their respective GPU usage:
  • Dying Light 2 - 99%
  • God of War (2018) - 97-98%
  • TW3 - 60-73%
  • Prey (2017) - 50-60%
 
Hi there,
So I've recently assembled a pc with the following specs:
  • AMD Ryzen 9 5900X 3.7GHz (4.8GHz Turbo), 12-Cores 24-Threads, AM4
  • MSI B550M PRO DASH, Chipset B550, AM4, mATX, DDR4
  • Memory DDR4 Geil Potenza, 16GB 3000MHZ, Black (x2)
  • Galax NVIDIA GeForce RTX 3080 SG (1-Click OC), LHR, 12GB, GDDR6X, DLSS, Ray Tracing
  • Super Flower LEGION GX PRO 850W, 80 Plus Gold
And although I've been mostly satisfied with the performance I'm getting, I can't shake the feeling that there might be something wrong with my build. On games like Cyberpunk and Deathloop GPU usage remains low, about 50% in Deathloop on ultra with RT enabled and 80-90% on Cyberpunk ultra RT mode (not as low but still not fully utilizing my GPU as seen in other benchmarks).
Do you guys have any idea what might be causing this? Feel free to ask me for more information as I believe what I've provided will most likely not be enough

P.S: Both Cyberpunk and Deathloop as well as all games listed below were running at 1440p and GPU temperatures are below 80 degrees Celsius at all times
P.S 2: I've checked and my graphics card is in a PCIe 4.0 x16 slot, so I've discarded this possibility as well

Things I've tried:
  • Setting windows power mode to best performance
Possible causes?
  • I'm aware my motherboard does not support XMP, could this be the issue?
Here are a few more games I tested and their respective GPU usage:
  • Dying Light 2 - 99%
  • God of War (2018) - 97-98%
  • TW3 - 60-73%
  • Prey (2017) - 50-60%
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall every gpu driver using DDU (clean and do not restart, also tick all option in Nvidia option in the ddu settings).
  • Uninstall all the processors (is a must, should be 24 on yours since it's 24 threads, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • reboot the PC to bios, disable AMD fTPM and secure boot (if enabled by default), save and exit, go to bios again, flash to the latest bios (do it again if you're currently using the latest bios) ver 7C95v3A the one with agesa 1.2.0.7, go to bios after finished updating, then load default or optimized settings, enable fastest xmp profile, then save and exit.

    Optional: disable CSM, enable Above 4G Decoding and Resizable bar option (these 2 options wont be available unless CSM is disabled). If gpu supports, why not XD

  • if successful, boot up to windows and install the latest Chipset driver (should be ver 4.08.xx as the time i write this), then reboot.

  • Install the latest nvidia driver, reboot, and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did), dont forget to put ram on slot 2 and 4. Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow

  • And check windows update if there is any and install them (except optional update).

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 
Sep 20, 2022
5
1
15
0
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall every gpu driver using DDU (clean and do not restart, also tick all option in Nvidia option in the ddu settings).
  • Uninstall all the processors (is a must, should be 24 on yours since it's 24 threads, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • reboot the PC to bios, disable AMD fTPM and secure boot (if enabled by default), save and exit, go to bios again, flash to the latest bios (do it again if you're currently using the latest bios) ver 7C95v3A the one with agesa 1.2.0.7, go to bios after finished updating, then load default or optimized settings, enable fastest xmp profile, then save and exit.

    Optional: disable CSM, enable Above 4G Decoding and Resizable bar option (these 2 options wont be available unless CSM is disabled). If gpu supports, why not XD

  • if successful, boot up to windows and install the latest Chipset driver (should be ver 4.08.xx as the time i write this), then reboot.

  • Install the latest nvidia driver, reboot, and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did), dont forget to put ram on slot 2 and 4. Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow

  • And check windows update if there is any and install them (except optional update).

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
Thank you for the suggestions, I'll try these tonight when I'm back from work
 
Reactions: Koekieezz
Sep 20, 2022
5
1
15
0
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall every gpu driver using DDU (clean and do not restart, also tick all option in Nvidia option in the ddu settings).
  • Uninstall all the processors (is a must, should be 24 on yours since it's 24 threads, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • reboot the PC to bios, disable AMD fTPM and secure boot (if enabled by default), save and exit, go to bios again, flash to the latest bios (do it again if you're currently using the latest bios) ver 7C95v3A the one with agesa 1.2.0.7, go to bios after finished updating, then load default or optimized settings, enable fastest xmp profile, then save and exit.

    Optional: disable CSM, enable Above 4G Decoding and Resizable bar option (these 2 options wont be available unless CSM is disabled). If gpu supports, why not XD

  • if successful, boot up to windows and install the latest Chipset driver (should be ver 4.08.xx as the time i write this), then reboot.

  • Install the latest nvidia driver, reboot, and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did), dont forget to put ram on slot 2 and 4. Download needed files (highlighted word) before doing step 1, do the step by orders.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow

  • And check windows update if there is any and install them (except optional update).

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
Hi Koekieezz,

I've tried running these steps but the issue still persists. There were some advantages to running it though, my BIOS was pretty outdated and my GPU had a single split cable powering it. Both are now mitigated.

Not sure if it helps but here's some data from a brief period running death loop, the average FPS during this entire period was around 76:


 

bdcrlsn

Distinguished
Dec 31, 2007
385
18
18,815
14
I had an issue similar to yours where a game wasn't utilizing the GPU (only 30-50%) and was limiting the FPS as a result. What I discovered was to disable Low Latency Mode in the Nvidia Control Panel under "Manage 3D Settings." That immediately solved my problem.
 
Sep 20, 2022
5
1
15
0
I had an issue similar to yours where a game wasn't utilizing the GPU (only 30-50%) and was limiting the FPS as a result. What I discovered was to disable Low Latency Mode in the Nvidia Control Panel under "Manage 3D Settings." That immediately solved my problem.
Low latency mode is disabled both globally and for the games specifically, thanks for the suggestion though!
 
Low latency mode is disabled both globally and for the games specifically, thanks for the suggestion though!
so you did all the steps by step right (not skipping the steps till end)?

on Nvidia Control Panel, i set to this:
  • Threaded Optimization = On
  • Quality = Max Performance
  • Power Management = Adaptive (not optimize or other, i always use adaptive)
  • MFAA = Enable
  • OpenGL= My gpu (1070)
  • Low Latency Mode = ON (not ultra, on is better for me on fps games)
maybe try those settings and see if it resulted anything

oh also you did enable Above 4G Decode and Resizable Bar right? if so, could you share a gpuz screenshot here?
 

ASK THE COMMUNITY

TRENDING THREADS