Question RTX 570 Bluescreen Problem

Jul 20, 2019
6
0
10
0
Hello :)
First of all sorry for my English, its not my native language but il try my best.

About a week ago, a bought RX 570 Sapphire Nitro + 8GB, guy who was selling it told me that it was used only for small amount of time and still have a Guarantee for 3 months, the price was fine so i went for it.
When i finally got it inside my case, i tried to install drivers from CD that came with the card, but they wont install at all, after install my PC restarted as it should but then AMD was giving me a message "no amd graphics driver is installed or the amd driver is not functioning properly" so i used Display Driver Uninstaller in safe mode and tried again with no luck. Then i started looking in google and found a program called "atikmdag-patcher", which i used and then i can finally instal drivers properly, so i think this guy was using this card for digging, and havent told me.

After I installed drivers from the CD i updated it to latest ones, using Radeon Control Panel, so with that sorted out i wanted to play some games and this is the where problems begins .

I wanted to play a game called Rising Storm 2 Vietnam, I set to Graphical options to defalut which was set to high/ultra, i played one round (30 min) and everything was fine, then when a map changes my PC went for bluescreen. I tried it again with lower Graphical options but with little improvement, I was able to play few more round then again, bluescren when map changed.

At this point I installed program called "WhoCrashed" who told me:

"On Sat 2019-08-10 13:18:36 your computer crashed or a problem was reported
crash dump file: C:\Windows\Minidump\081019-15444-01.dmp
This was probably caused by the following module: ntoskrnl.exe (nt+0x93970)
Bugcheck code: 0x1E (0x0, 0x0, 0x0, 0x0)
Error: KMODE_EXCEPTION_NOT_HANDLED
file path: C:\Windows\system32\ntoskrnl.exe
product: Microsoft® Windows® Operating System
company: Microsoft Corporation
description: NT Kernel & System
Bug check description: This indicates that a kernel-mode program generated an exception which the error handler did not catch.
This might be a case of memory corruption. This may be because of a hardware issue such as faulty RAM, overheating (thermal issue) or because of a buggy driver.
The crash took place in the Windows kernel. Possibly this problem is caused by another driver that cannot be identified at this time."

So checked RAM first, i run a windows memory diagonsys, it show no errors, then i run "MemTest64" for 8 loops and again no error.
Then i turn to heat problem so i downloaded program called "FurMark" and run it 5 times in a row, highest temperature was 69 celsius degrees, so i think its not heat, but i already opened case in order to bring more cold air.
I also switched my Minimal energy limit to Full in Radeon Control center, still no improvement.

Then i analized another Bluescreens using WhoCrashed and I found this:

"On Wed 2019-08-14 21:31:52 your computer crashed or a problem was reported
crash dump file: C:\Windows\MEMORY.DMP
This was probably caused by the following module: atikmdag.sys (atikmdag+0xC85E9)
Bugcheck code: 0x1E (0x0, 0x0, 0x0, 0x0)
Error: KMODE_EXCEPTION_NOT_HANDLED
file path: C:\Windows\system32\drivers\atikmdag.sys
product: ATI Radeon Family
company: Advanced Micro Devices, Inc.
description: ATI Radeon Kernel Mode Driver
Bug check description: This indicates that a kernel-mode program generated an exception which the error handler did not catch.
This might be a case of memory corruption. This may be because of a hardware issue such as faulty RAM, overheating (thermal issue) or because of a buggy driver.
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: atikmdag.sys (ATI Radeon Kernel Mode Driver, Advanced Micro Devices, Inc.)."

I was having the latest drivers already installed (Adrenalin 2019 Edition 19.5.2) so i reversed back to those that came with CD (Vulkan™ Driver Version 1.5.0).
After that one day I was able to run the whole campaign in Rising Storm 2 (its like 3-5 hours), and other day I seen less (like 1 or 2) Bluescreens.
I was also playing the Rome II Total War and there i got somewhat lighter bluescreens, i mean when in main menu, after while my monitor is going black and its showing "NO PC SIGNAL" message, although i can still hear the music, but i cant do anything to "wake him up" so only thing i can do is restart my PC, also one time it went bluescreen after pressing the next turn button. The only game that works for me its PES2018.

I honestly dont know what to do anymore, i think maybe formating the system can help but i dont know if this would solve the problem, although im using it since 2016 so maybe this is a problem. I have also 6 important and 54 optional actualisations in Windows update, i never really bothered about those, I use Auslogics Disk Defrag Touch at every end of the month, and Im using 360 Total Security as my antivirus. Also i use CCleaner every time i turn on my PC.

I am really grateful for your help.

Here is my specification:

CPU: AMD-FX(tm) 4300 Quad Core Processor 3.80 Ghz
GPU: Radeon RX 570 Sapphire Nitro + 8GB
Power Supply: Zalmann ZM600-LX 600 Watt
Motherboard: Gigabyte 78LMT-USBR3 R2
OS: Windows 7 Home Premium SP1.
 
Jul 20, 2019
6
0
10
0
Thank you for you help cin19

Its hard for me to belive that this is PSU fault, but im no expert.
This is what im going to do:
Im going to Format my system and try to install this GPU on fresh windows 7,
If bluescreens will continue, this means that that you are right, and I need new PSU.
 

ASK THE COMMUNITY

TRENDING THREADS