Question RTX2060 + RYZEN 5 3600 Getting low gpu and cpu usage

Aug 20, 2021
3
0
10
0
So recently I have upgraded my gpu from an fx-8300 to a ryzen 5 3600 alongside with some other parts. I thought that after that all my performance issues would be gone, but now I'm facing a very strange one that I can't seem to find any solution for it on the internet. In almost all my games (except for Cod Warzone and Black Ops Cold War), I noticed that I have been getting farely low gpu and cpu usage (GPU being at around 50% all the time and CPU at 40-60%). Because of that many games that I wanted to play for a long time have been really annoying and unpleasant to play, like GTA V that I get around 80-50 fps in the city and other games like Fortnite I end up getting annoying stutters due to gpu usage drop mid game (sometimes happens in COD Warzone too) . I was wondering if there were any solutions for my problem , I already tried uninstalling nvidia drivers, checking ram for errors and gpu stress testing, but all of them turned out being fine or not making any changes. I am getting kind of worried because I can't find anything that could help me as almost all the threads I find on the internet don't have my specific case and end up being cpu bottleneck's.

My system specs:

Motherboard: B450M Steel Legend

GPU: Zotac Gaming RTX 2060

CPU: Ryzen 5 3600

Memory: 16 GB DDR4 3200Mhz Corsair Vengeance RGB Pro (Dual Channeled) (XMP ON)

PSU: Corsair VS 650W

SSD: Kingston 120 GB

HD: WD Purple 1 TB

CPU Cooler: Corsair H45

(Temperatures on my system seemed to be fine, going around 60-65 C ingame)

My rtx 2060 has been on my system for around a year now, but I don't think that would be the problem in this case.
Another thing I noticed is that my ryzen 5 3600, although It wasn't overclocked, is showing a base speed of 3.60 Ghz in the task manager and running at 4.10 Ghz most of the time (Really don't know how to fix that problem)
Thanks
 

dorsai

Distinguished
You shouldn't change motherboards without doing a complete fresh OS install along with it. Pretty much every component is different between the old and new board so it's bound to cause driver issues and conflicts.
 
Aug 20, 2021
3
0
10
0
Hey sorry for not being able to respond these messages earlier, was kinda busy this weekend. I did a clean windows install as you guys suggested but I'm still getting the same problem, hopped into gta v with graphics on max and Im getting 40% gpu usage and 40% cpu usage on average, is there anything else I can do?
 

ASK THE COMMUNITY

TRENDING THREADS