Question Running RX 460 with Ryzen 3 3200g - driver issues?

Primal_Mojo

Reputable
Sep 4, 2016
18
0
4,510
0
Hi there! I just put together identical builds for myself and my fiancee about a week ago, and while I was out of town for the weekend, my stepson decided he wanted to try adding our old graphics cards to see if they performed better than with just the Vega 8 graphics on the Ryzen 3 3200g.

First things first, I want to say that before I left for 4 days, my computer was running fine - no BSOD, everything loaded fine (except windows doesn't want to activate on either machine). All programs were running as expected.

Last night when I got home, my RX 460 was installed, and my stepson said he had it all working fine - that he only had one BSOD and after that it was fine. He installed Heaven Benchmark (his idea) and bumped RAM to 2933 on my request.

Here's the new build breakdown:
ASUS Prime x470 Pro MB
Ryzen 3 3200g 4 core with Vega 8 Graphics
Corsair Vengeance LPX 16gb RAM
Corsair VS650 Power supply
2TB WD Blue HD
Rosewill Challenger mid case
24" BenQ monitors

Added to my fiancee's build was his RX 550 4GB card, and his is stable and working perfectly. Added to mine was my RX 460 2GB card, which previously had no issues with the exact same HD (fiancee needed a 2 TB, I already had one hooked up). Now, I've gotten 4 different BSOD (page fault in non paged area, system service exception, critical structure corruption, and cache manager). The 460 is still enabled, but I've tried both the auto detect and the card specific drivers directly from AMD, and even though it shows me completing installation and having me restart the computer, when it comes back up and I check the device manager, it still says the drivers aren't loaded.

Also, I have DX 12 on my system, but when I open the game I'm trying to get into, it tells me that DX11 feature level 10.0 is required to run the engine.

Please help! I'm frustrated because I had it working fine, and I wasn't here when my stepson tried up upgrade it and now I don't know where to start to fix all of this mess.

BTW, I already uninstalled Heaven's Benchmark.

EDITED TO ADD: I also found Cinebench on my computer, another benchmark tool my stepson had installed - it has since been uninstalled as well.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS