Question RUST - Low FPS on higher end gaming pc

TSB_Oku

Reputable
Apr 29, 2019
25
2
4,535
0
So basically I've been having this issue for over a year now but I used to be able to play rust at over 144 fps consistently last year, for some reason now I cannot go beyond 80fps I literally get 80 fps with max settings as well as lowest settings (i have checked both nvidia control panel and rust setting to see if vsync is on or some fps cap is on but there isnt any. Here is my specs: RTX 2080, 32gb (brand new) 3600mhz ram, b350-f motherboard and ryzen 7 2700X. Any help would be much appreciated.
 
So basically I've been having this issue for over a year now but I used to be able to play rust at over 144 fps consistently last year, for some reason now I cannot go beyond 80fps I literally get 80 fps with max settings as well as lowest settings (i have checked both nvidia control panel and rust setting to see if vsync is on or some fps cap is on but there isnt any. Here is my specs: RTX 2080, 32gb (brand new) 3600mhz ram, b350-f motherboard and ryzen 7 2700X. Any help would be much appreciated.
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 16 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • restart the pc to bios, disable AMD fTPM and secure boot if it was turned on by default, save and exit, go to bios again, flash to the latest bios, then after updating bios go to bios again, then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot. Try to take a look on power plan if amd ryzen balanced power plan is available, if it's not then its okay.

  • Install the latest nvidia driver , and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders. You might want to downclock your ram to 3533 or 3466 (or even 3400 and below) since Zen+ cant take 3600 mostly. Just enable the fastest DOCP Profile and lower the ram freq. Make sure ram is on slot 2 and 4.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 

TSB_Oku

Reputable
Apr 29, 2019
25
2
4,535
0
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 16 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • restart the pc to bios, disable AMD fTPM and secure boot if it was turned on by default, save and exit, go to bios again, flash to the latest bios, then after updating bios go to bios again, then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot. Try to take a look on power plan if amd ryzen balanced power plan is available, if it's not then its okay.

  • Install the latest nvidia driver , and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders. You might want to downclock your ram to 3533 or 3466 (or even 3400 and below) since Zen+ cant take 3600 mostly. Just enable the fastest DOCP Profile and lower the ram freq. Make sure ram is on slot 2 and 4.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
Thanks for the help ill give it a go over the next couple days and update :)
 
Reactions: Koekieezz

TSB_Oku

Reputable
Apr 29, 2019
25
2
4,535
0
@Koe
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 16 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • restart the pc to bios, disable AMD fTPM and secure boot if it was turned on by default, save and exit, go to bios again, flash to the latest bios, then after updating bios go to bios again, then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot. Try to take a look on power plan if amd ryzen balanced power plan is available, if it's not then its okay.

  • Install the latest nvidia driver , and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders. You might want to downclock your ram to 3533 or 3466 (or even 3400 and below) since Zen+ cant take 3600 mostly. Just enable the fastest DOCP Profile and lower the ram freq. Make sure ram is on slot 2 and 4.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
Hey that actually helped alot, Thank you.
 
@Koe


Hey that actually helped alot, Thank you.
so you did follow it step by step in order, and it fixed?

for if you use ethernet, and installed armoury crate and other rog apps, uninstall them and the ethernet driver, then install the intel lan driver, and reboot, then install armoury crate if you need it, idk if it includes the lan optimizer thing from the install.
 

TSB_Oku

Reputable
Apr 29, 2019
25
2
4,535
0
follow this step by step in order (read till end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart).
  • Uninstall all the processors (is a must, should be 16 on yours, also when it asks for restart, click on no and keep uninstalling all processors) on device manager like this:


  • Uninstall AMD Chipset Software in control panel (if there is none, skip it.)

  • restart the pc to bios, disable AMD fTPM and secure boot if it was turned on by default, save and exit, go to bios again, flash to the latest bios, then after updating bios go to bios again, then load default or optimized settings, disable CSM, enable Above 4G Decoding and Resizable bar option if you want to (these 2 options wont be available unless CSM is disabled), then save and exit.

  • boot up to windows and install the latest Chipset driver (should be ver 4.03.xx), then reboot. Try to take a look on power plan if amd ryzen balanced power plan is available, if it's not then its okay.

  • Install the latest nvidia driver , and then connect to internet.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did). Download needed files (highlighted word) before doing step 1, do the step in orders. You might want to downclock your ram to 3533 or 3466 (or even 3400 and below) since Zen+ cant take 3600 mostly. Just enable the fastest DOCP Profile and lower the ram freq. Make sure ram is on slot 2 and 4.

  • Run cmd as admin, then do chkdsk /x /f /r, after that do sfc /scannow.

  • And check windows update if there is any and install them (except optional update). Don't forget to turn on Hardware Accelerated GPU Scheduling (Nvidia GPUs only) in graphics settings and reboot.

  • Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
after playing for a couple hours its now back to the 70fps cap that i was getting before. i had to cap my ram at 2600 because it kept crashing the pc. do you think it would be better do upgrade my motherbaord to a x570?
 

TSB_Oku

Reputable
Apr 29, 2019
25
2
4,535
0
so you did follow it step by step in order, and it fixed?

for if you use ethernet, and installed armoury crate and other rog apps, uninstall them and the ethernet driver, then install the intel lan driver, and reboot, then install armoury crate if you need it, idk if it includes the lan optimizer thing from the install.
Yep, I followed every step in order.
This happens with both ethernet and internet would u say its an isp issue?
 
after playing for a couple hours its now back to the 70fps cap that i was getting before. i had to cap my ram at 2600 because it kept crashing the pc. do you think it would be better do upgrade my motherbaord to a x570?
no need for X570 if you dont go robust on overclocking, a decent priced B550 is also good like B550M Pro4, or even a decent priced B450 is also good if you dont need pcie 3.0, but mostly, a cpu upgrade would be better, just jump directly to Zen 3, you could go as cheap as Ryzen 5 5500, or as good as Ryzen 7 5800X3D, pair it with your ram and it could run 3600mhz no prob! Performance increase is great, since my friend went from 2600 to 5600G and it games really good, while also compiling codes faster (thats what he said)

The ram cant run 3600mhz full speed due to Zen+ architechture, but motherboard also plays a factor there.

If you wish to do a good Ram OC or planning on buying a 4000mhz+ ram and want to leave xmp as it is, then go for 5500 since its 5600G but no igpu, pretty decent IMC for overclocking just like using intel comet lake cpus. But for the best gaming cpu, go for 5800X3D, downsides are only cant OC ram to 4000mhz real easy unlike 5500 due to architecture.

Yep, I followed every step in order.
This happens with both ethernet and internet would u say its an isp issue?
Either internet or ISP issue (or router issue could be), if you have another gaming capable device, plugged in the ram and no prob, then prolly the mobo issue.
 

ASK THE COMMUNITY

TRENDING THREADS