Question Rust won't load in...

Mar 5, 2019
8
0
10
0
I've been playing Rust since I've played on my mac in 2016 everything ran smooth and i never had a problem. I finally got my new pc and rust just doesn't want to load, during the "Skinnable Warmup" or "Asset warmup" my game just crashes.
I have a

Windows 10 Pro 64-Bit
Nvidia Geforce GTX 1050
Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz
8gb ram
1TB Hard Drive

Im pretty sure it's just a bug in this game I've tried uninstalling different launch options.

If anyone has any clues on what this might be much would be appreciated.
 
new build? fresh install?... have you installed all the vcredists from microsoft?, if not do so (installing them all from 2008 to 2017 solves a lot of issues)

have you checked the even logs (control panel/admin tools/event viewer)
see if its missing a dll or something like it. if so google whats missing and post back...
dont download 3rd party dlls without checking with the guys here.
 
Mar 5, 2019
8
0
10
0
new build? fresh install?... have you installed all the vcredists from microsoft?, if not do so (installing them all from 2008 to 2017 solves a lot of issues)

have you checked the even logs (control panel/admin tools/event viewer)
see if its missing a dll or something like it. if so google whats missing and post back...
dont download 3rd party dlls without checking with the guys here.
Yep, done this all as we speak, restarted my computer tried logging on as I’m loading I get a solid 1fps and the game continues to crash still on the asset warmup
 

ASK THE COMMUNITY

TRENDING THREADS