Question rx 470 gaming 8GB no display

Dec 10, 2019
3
0
10
0
Hi,


I have issue with MSI rx 470 gaming 8GB (without X version). I bought used card, that should be working but it don't. (seller helps me to find reason, he can change this one to another, seems that he don't want to cheat me, he says that he tested it before selling). I did plenty of things, i will try to write here some that i remember.

Computer:

Mobo: Asrock 970A-G/3.1

CPU: AMD FX 8350

GPU: old one - radeon hd 6750 (working); new one - rx 470 gaming 8GB (no display)

PSU: old one - OCZ CXS500W (working with earlier setup); new one Corsair RM750X (bought to check if PSU isnt problem; staying whith this one)

RAM: Combination of few different DDR3 - Savage 2400 (4GB); OCZ 2x2GB + 1x2GB (other series)

M.2 disc wich i removed to use PCIE2 slot (works m.2 or pcie2, it can't work both in same time - mobo specification)


First impression - I took card and installed it in mobo, also added power cords. Power button - no display (black screen from the beggining, cant even open bios, no post; i have no beeper to check what signals give me mobo).

I tried to remove some RAM sticks, and run with only one (once OCZ, once Hyperx, no difference - even tried to change their slots). Unpluged hdd to check if helps.

Few of steps i did with pluged my old GPU - like changing my bios settings to default. or see if bios recognise that there is something in second PCIE slot (yes i also installed new one in sec. slot to make sure if there is any signal. BIOS (or should i call it UEFI) sees card (that something is there). Changing their positions to PCIE1 - new one; PCIE2 - old one was different - there was no display from any of cards (old one did same as new; new one in PCIE1 still no display).

I also tried to reset bios CMOS, + install newest bios for motherboard. (by online asrock flash and by manual from USB). I also tried to did trick with PCIE1 (old one); PCIE2 new one by starting operating system (windows 7 64bit) and adding new bios to rx 470 wich i can see in device manager as "Standard VGA ...". (installed few bioses to this card to be sure). I used DDU to remove all drivers, and installed newest drivers for rx 470 (after thath device manager recognized card as it should). After each step i tested new GPU by uninstalling old one and putting new one in PCIE1 slot. (i did it really plenty of times, it took me many hours...). I also tested bios option with UEFI ONLY (not legacy mode). I probably wrote here only part of things that i did, i may add some more later.

Hope you can help me. ;/
 

ASK THE COMMUNITY

TRENDING THREADS