Question RX 480 - black screen and turbo fans

Feb 10, 2020
16
0
10
0
hi all,

I've just upgraded to a Sapphire RX480 as the first part of a slew of upgrades. It keeps crashing my PC - the first couple of times I would barely have opened a game and it would blackscreen and spin its fan at full speed. I fiddled with the settings and basically turned the fans right up, I.E so that they're spinning VERY LOUDLY when it gets to like 50 degrees C, and 100% at 70c.

it put up with about ten minutes of BeamNG drive (I tried this as it's fairly graphically complex and should have given this 8gb card a run for its money) even on medium graphics it crashed the game, however it did not this time crash to a black screen

while the CPU struggles and runs at 100% (specs below) the GPU shouldn't have an issue at this level, surely? It even crashed trying to start skyrim, which my 750 TI was able to run brilliantly without complaint! even when the fans speed up the air coming from the exhaust is cool, or lukewarm.

i'm pretty stumped, any help is much appreciated - my whole PC is running really slowly and sluggishly now as well!!

Specs: Gigabyte ga-f2a68m-hd2 MoBo, Athlon x4 860k, 8gb ddr3 ram, Sapphire RX 480 8GB, EVGA bronze 500w psu, windows 7. I will be upgrading MoBo, CPU, RAM soon, but is it worth it if I'll have to listen to a hoover every time I want to play a game!?
 

cin19

Titan
Moderator
I've just upgraded to a Sapphire RX480 as the first part of a slew of upgrades. It keeps crashing my PC
  1. It maybe from the GPU, if it is the used one. You can test it in other PC, if you can.
  2. It maybe from the driver, you may try to use the DDU to uninstall the GPU driver first, then reinstall the GPU driver.
  3. It maybe the MB does not have the newer BIOS. And keep in mind, if you don't do it right, you may brick the MB.
  4. It maybe the PSU that can't handle the rx480.
 

ASK THE COMMUNITY

TRENDING THREADS