Question RX 480 Flashing

tibsy

Commendable
Jul 10, 2019
140
2
1,585
0
Hi
i recently got hold of some sapphire nitro rx 480 8gb cards which had previously been used for mining. i used gpu z to check the specs of the graphics card. in the gpu clock section it said 0 mhz and 1306 in the default clock. upon research i found out the miner probably flashed the card with a mining bios or something. i have installed the drivers but the gpu is not being shown as well as the windows is not recognising the graphics card. i can see the name of the gpu in the gpu z software so it is a legit card. i got the bios from the techpowerup site which matched the default clock speed and memory speed of the gpu and downloaded it. i used atiflash 2.94 to to browse and and pressed the program button to flash it. it flashed the card and rebooted it. And now i could see the clock speeds and temperatures were also being shown using msi afterburner and hwinfo. so the windows recognised the driver. so i ran some benchmarks and temps were a little high but the card was WORKING. i played some games and was also working fine apart from the temps which were in the 70 degrees range. i turned the pc off and turned it on the next day and all of a sudden the pc is not showing any video output. at boot the fans of the gpu were also not spinning. so i tried the gpu in another rig and also got the same result. NO OUTPUT. so is the card dead or what. what did i do wrong?? any help would be greatly appreciated.
 

ASK THE COMMUNITY