Question RX 480 nitro 4gb stopped working, need help

orangedu02

Commendable
Jun 12, 2017
20
0
1,520
1
I got an rx 480 intro 4gb a couple of days ago from a friend for cheap, I worked fine the day I got it, I tested it in a couple of games and monitored temperature and stuff, nothing was out of the ordinary 75° C under load I consider that to be perfect. No fps dips no stutter or lag and everything was running smoothly. The games I tested were; Assassin's Creed - Odyssey, Fallout 4, Rage 2.

Next morning I turn on the computer and there was no signal to my monitors, I restarted and still nothing, my monitor kept saying there as was no signal coming from my computer but is was detecting that the display port was plugged in, I tried a different port, even a DVI and HDMI, still nothing. I plug in my old gtx 1050 and it ran fine. I have no second system to test the card in and all my friends own laptops.

my computer is a dell inspiron 3847, so an OEM motherboard that is running in legacy mode bios. Everything is up to date, bios, drivers and all. Running a windows 7 pro 64.

specs are :

i5 4460

8gb ram 1600

240 SSD

1tb HDD

PSU: EVGA 600BR 80+ bronze.



what's bugging me is that it worked flawlessly the previous night. I've read that it could be that I may need a newer mobo.

Any suggestions would be much appreciated and thank you.
 

ASK THE COMMUNITY

TRENDING THREADS