[SOLVED] Rx 570 White blinking light

Status
Not open for further replies.
Mar 9, 2020
31
0
40
0
PC SPECS:
CPU: RYZEN 5 2400G (APU)
GPU: RX 570 8gb from GIGABYTE
RAM: 8GB DDR4 VIPER RAM
MOTHERBOARD: MSI B450M PRO-VDH-PLUS
SSD: INTENSO 120GB
HDD: TOSHIBA 1TB
PSU: COOLER MASTER MasterWatt Lite 600W PC
i use windows 10 newest version


i had an issue when gaming with graphics card in the early stages that it had a blinking white led light on top of the PCI-E slot. Now my Graphicscard doesnt turn on either way i have to remove the card or otherwise i have no access to my Pc.
if someone could tell me if it is a bug or if doing something wrong because maybe theres something wrong with the PSU (i can give it back) or some different stuff. Ty for your help
 
All I am saying is that Gigabyte says that's what the blinking light indicates......"bad power".

Now....of course the blinking light may be in error.....and you may have "good power".....and there is something wrong with the card and it's indicating "bad power"....in which case you would have a bad GPU.
 
Mar 9, 2020
31
0
40
0
I think the light indicates "bad voltage" if it's not steadily let.
I would replace the PSU.

"According to gigabyte website white led blinking means abnormal power supply. "
can ask you for something i had the rx570 for 4months in the four months i had a psu which was called 400W Bequiet System Power 9 so basically what happend was the same issue white led blinking and i could get into the login screen after reaseting the card a couple of times aswell as the ram sticks everything worked then but the led was still blinking.
Now i have this PSU COOLER MASTER MasterWatt Lite 600W PC which i bought from saturn i still have the Bill for it so i could possible give it back. i can turn on the pc with the graphics card but the led is still blinking and i only get into the login screen as where i only see a blackscreen with the fans stopping to spin on the Rx 570 and the led still blinking.
I would appreciate a answer from you again cuz im struglling with this problem for days now

Edit: when trying to set my mobo to UEFI and turn off integrated graphics and put the hdmi cable in the gpu i only see artifacted screen restarting over and over again when reaching the login screen led still blinking.

View: https://imgur.com/a/kJHVTG2
 
All I am saying is that Gigabyte says that's what the blinking light indicates......"bad power".

Now....of course the blinking light may be in error.....and you may have "good power".....and there is something wrong with the card and it's indicating "bad power"....in which case you would have a bad GPU.
 
Mar 9, 2020
31
0
40
0
All I am saying is that Gigabyte says that's what the blinking light indicates......"bad power".

Now....of course the blinking light may be in error.....and you may have "good power".....and there is something wrong with the card and it's indicating "bad power"....in which case you would have a bad GPU.
ty for the info i will test the gpu in a other system and we will see what is going to happen
 
Mar 9, 2020
31
0
40
0
The Card was Faulty i send it back after 4 months as they replied to send the GPU back. They will send me a New functional GPU or give me my money back
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS