[SOLVED] RX 5700 lower clock speed than should be

May 21, 2021
6
0
10
0
I set my rx 5700's clock speed to 1700 mhz, but at stress tests clock speed is getting stuck at 1660 mhz. I tried setting clock speed at 1750 mhz and stress tests clock speed getting stuck at 1710 mhz. I reinstalled drivers after uninstalling the old one with DDU but nothing changed.
 

tennis2

Judicious
My bad, I guess that isn't an option in AMD 5000 series.

On to undervolting! THIS IS A SAMPLE SCREEN FROM AMD, NOT NECESSARILY FROM A RX5700

Best just to enter the new voltage values numerically in the boxes. Try subtracting 50 from each of your stock voltage values and test stability (and clock speed)

You can also enable "Power Tuning" (right side of screen above) and increase the power limit above 100%. Increasing the power limit does just that, it allows the GPU to pull >100% of the stock power limit. It's better to undervolt first (which reduces power draw, hence heat and noise also). If the stock limit is 180W and you're hitting that limit before the frequency hits max, undervolting will reduce power draw and allow the max frequency to be reached at/under 180W power draw. Increasing the power limit means the max frequency will be reached at >180W power draw.
 
Last edited:

tennis2

Judicious
My bad, I guess that isn't an option in AMD 5000 series.

On to undervolting! THIS IS A SAMPLE SCREEN FROM AMD, NOT NECESSARILY FROM A RX5700

Best just to enter the new voltage values numerically in the boxes. Try subtracting 50 from each of your stock voltage values and test stability (and clock speed)

You can also enable "Power Tuning" (right side of screen above) and increase the power limit above 100%. Increasing the power limit does just that, it allows the GPU to pull >100% of the stock power limit. It's better to undervolt first (which reduces power draw, hence heat and noise also). If the stock limit is 180W and you're hitting that limit before the frequency hits max, undervolting will reduce power draw and allow the max frequency to be reached at/under 180W power draw. Increasing the power limit means the max frequency will be reached at >180W power draw.
 
Last edited:
Scroll down farther on your Sensors tab. You're looking for the line labeled "PERFCAP REASON"
That option is not available in AMD GPUs in general, afaik.

I set my rx 5700's clock speed to 1700 mhz, but at stress tests clock speed is getting stuck at 1660 mhz. I tried setting clock speed at 1750 mhz and stress tests clock speed getting stuck at 1710 mhz. I reinstalled drivers after uninstalling the old one with DDU but nothing changed.
You are either hitting power, or thermal thresholds. More likely power. Undervolting as already suggested, will help.
 

ASK THE COMMUNITY