Question RX 580 dual monitor issues under load

mat1200012

Commendable
Oct 4, 2017
3
0
1,510
0
Hi all,

I recently upgraded my graphics card. I previously ran a GTX 750 Ti with a dual monitor setup.

Both monitors are a bit older (one is VGA only (Hanns-G HW173), the other is VGA and DVI-D(DELL SE198WFP)). I had no issues with them on the old graphics card.

Both monitors are running over adapters (VGA to DVI-D and VGA to HDMI). When only one monitor is hooked up, there are no issues. When both monitors are connected and the GPU is under load, the screens will rapidly turn on and off and windows and icons will get moved from one to the other, as if the signal was lost repeatedly. When not under load (browsing, movies etc.) they both run fine.

I ruled out cable and adapter issues as I've switched the cables and adapters between both monitors and they work fine. The PSU is a 500W Thermaltake so it should handle the load. Newest drivers are installed and have been reinstalled (in safe mode and all that) and I have tried upping the power limit in WattMan. I noticed in WattMan that the Activity, Power and GPU all drop when the flickering occurs.

Both monitors have a 1440x900 native resolution, although the DELL monitor is slightly bigger than the other one. The flickering stops as soon as I unplug one of the monitors, whichever one.

Is the problem due to the VGA connections? On a forum on AMD's website someone posted that the GPU does not natively support VGA and adapters can cause issues, but then running the monitors individually seems to work just fine.

At this point I'm trying to just figure out if the card has an issue so I can return it, if my MoBo cannot handle it, or if it's a software problem.

Here are the rest of my specs:
AMD FX-8300
16GB RAM
Asrock 980de3/u3s3 r2 MoBo
The manufacturer of the GPU is XFX

Any suggestions are greatly appreciated!
 

ASK THE COMMUNITY

TRENDING THREADS