Question RX 580 not booting in gaming mode

Jan 25, 2020
4
0
10
0
Hello. I recently bought a Sapphire Pulse RX 580 8GB card. This card has a dual BIOS switch (Gaming or Compute). The Compute mode is for mining and the paper tha comes with it says tha it may be unstable in gaming. The thing is that the card doesn't boot in gaming mode, only in compute. I've searched a lot and i think that the problem is that my rig is from 2011 and my mobo doesn't support pci express 3.0 (only 2.0). I have upgraded again in the past with a Gigabyyte OC Gaming gtx 960 4GB with no problems. Can anyone help please? Thanks in advance. My pc specs are: i7 2600k , sapphire Pure Black p67 Hydra (mobo), 8gb Ram, Cooler Master Silent Pro 850W (Bronze) .
 
Jan 25, 2020
4
0
10
0
First of all thanks both of you for the reply.
I haven't done much with the bios because I've seen posts that say that is dangerous in some cases (not sure if that is legit but I'm afraid of messing up things more). The bios have only legacy mode and no option for uefi due to mobos age. The only thing I update through ddu is the pci express and chipset drivers (also done by a friend who is a programmer). Also the age of the psu may be an issue despite its capacity? In that case first I would try an other psu and if the problem persists I will ghave a technician do any updates regarding the mobo. Thank you again for your replies!
 

lynx1021

Reputable
Feb 17, 2016
779
88
5,040
38
Because you have a legacy bios the GPU may not be booting in "gaming mode" as it is looking for a UEFI bios. At one time a lot of the Sapphire cards had bios switches for legacy or UEFI motherboards. I tried a EVGA RX460 in my motherboard but it didn't work, found out that the XFX RX460 GPU's work in my motherboards because they are legacy bios compatible.
 
Jan 25, 2020
4
0
10
0
Yes I suspected that after some search I did. The downfall of compute mode is that a the card is underclocked (checked with msi afterburner) and loses in terms of performance. Also it behaves very inconsistent sometimes (depends on the game of course). For example in AC Odyssey have a 10 to 15 fps difference in the same areas. One day it plays smoothly and another it lags. Anyway thank you for your time mate!
 
Jan 25, 2020
4
0
10
0
I run the benchmark in AC Odyssey to see if I was imagining things and the results are these: Yesterday I had 36 fps avg, 17 min and 59 max. Today I had 45 avg, 28 min and 70 max. Everything with the same settings.
 

ASK THE COMMUNITY

TRENDING THREADS