Question Rx 580 not detected? No power? Dead?

Oct 27, 2021
2
0
10
0
Hi guys My rx 580 sapphire nitro + 8gb doesn't want to turn on anymore. when I press the start button the sapphire logo lights up in blue and pulses (without remaining fixed) but fans do not spin (even on startup) and there is no signal.
I tried the card on different configurations: different pc (different mobo, RAM, chipset) different PSU (Corsair 850, Corsair 750), different power cables, tried to put it on a riser: same result.
Obviously I tried the basic solutions: swap pcie slots, clear cmos, swap ram, change bios gen, disable integrated graphic, etc.
My specs 1st pc Mobo b450 gaming plus Chipset ryzen 5 PSU Corsair 750
2nd pc Mobo Aorus z370 gaming 7 Chipset i7 PSU Corsair 850
The card worked till yesterday but after I tried to put all my gpu on 1 mobo with my 2 psu and the Add2PSU Chip its gone. Only the rx 580, all the others still working like always.
PS: I made my test with only the rx580 connected. With the same cables, Psu etc any other card works fine.
—— In my opinion the GPU don’t load enough power from PSU, as I said it start with the blue logo breathing like if the card is connected only by the pcie slot, but not fans on startup -
Please help me
 

ASK THE COMMUNITY

TRENDING THREADS