Question Rx 580 not displaying

Jun 28, 2020
2
0
10
0
I bought a prebuilt from BestBuy linked below

https://www.bestbuy.com/site/cyberpowerpc-gaming-desktop-amd-ryzen-5-3600-8gb-memory-amd-radeon-rx-580-2tb-hdd-240gb-ssd-black/6362427.p?skuId=6362427

It has been working fine for a week but now I’m having a display issue. I’ve reinstalled the gpu and still no fix. There is a blue light on the gpu with the pci e plugged in. However there’s another pcie cord unattached. The gpu fans are not spinning as well.

I checked the display with another computer and it’s working fine. My HDMI cord is also plugged into the gpu

also sorry but I have no clue about any of this and I’m just trying to google and fix stuff as I’ve never worked on a pc
 
Jun 28, 2020
2
0
10
0

Here’s a picture. I found that pcie cord in the hole with the other wires unplugged and just stuffed down there. I was trying to look if there’s somewhere to plug it in but it looks like the screws are tamperproof
 

Ferimer

Distinguished
Aug 19, 2011
847
69
19,090
16
I bought a prebuilt from BestBuy linked below

https://www.bestbuy.com/site/cyberpowerpc-gaming-desktop-amd-ryzen-5-3600-8gb-memory-amd-radeon-rx-580-2tb-hdd-240gb-ssd-black/6362427.p?skuId=6362427

It has been working fine for a week but now I’m having a display issue. I’ve reinstalled the gpu and still no fix. There is a blue light on the gpu with the pci e plugged in. However there’s another pcie cord unattached. The gpu fans are not spinning as well.

I checked the display with another computer and it’s working fine. My HDMI cord is also plugged into the gpu

also sorry but I have no clue about any of this and I’m just trying to google and fix stuff as I’ve never worked on a pc
fans not spinning usually that is normal, most newer GPUs don't start up their fans until they reach a certain temp or under load. You say it works fine with another computer? what do you mean by that? the GPU works within another build? or a different monitor?
 

ASK THE COMMUNITY