Question Rx 580 power issues

Joshua Streeter

Reputable
Jul 31, 2014
6
0
4,510
0
So long story short I didn't use my PC for a while (3 months) finally unpacked it and set it up again played a game of HoTS and noticed it was very bad average fps (this was not the standard the last time I had used the PC a few months ago) game started at 60 fps and dropped and stuttered a lot whenever stuff happened on screen

I ran DDU and reinstalled 4 different Adrenalin versions with no success all 4 a few months apart I've been using passmark and Heroes of the Storm to check it my passmark is consistently 40% of what it should be and Heroes is very choppy when it should be working fine

I tested the CPU and RAM independently so those 2 aren't the problem


One off thing I've found is that my power draw according to wattman performance monitoring overlay is generally within 75-110w which seems extremely low for an RX580 it gets to 100% usage but the memory clocks often is half of what it should be 1000 vs 2000 and it never uses more than 2.5gb of it's VRAM I'm planning on using a different GPU to check it tomorrow I did try using different 2+6 connectors from the power supply but that didn't seem to work I'm going to try to plug those into a different pcie power slot on the PSU in case the one they are currently plugged into is bad I can't think of anything else that could be the problem unless my 580 decided to die while not being used for 3 months
 

Joshua Streeter

Reputable
Jul 31, 2014
6
0
4,510
0
Corsair HX750 Platinum and it's about a year old I used a PSU tester on it earlier and it tested fine
All the temps are fine as well

Room is always at 78F
CPU is 40C~ idle 75-80 stress test
GPU was ~50C through all of the testing and game testing never got above 55C (at about 110w which I think is about half of what it's supposed to be usage wise)
 

ASK THE COMMUNITY

TRENDING THREADS