[SOLVED] RX 580 Voltage Spike

Jul 28, 2019
41
0
40
1
The maximum voltage for my GPU should be around 1.150v-1.187v as it has always been @ 1365 MHz and it has always peaked at 1.187v since I bought it.

But then I noticed that it peaks at 1.350v which doesn't look safe, I didn't overclock the GPU and I didn't touch any of the voltage settings, it's still at 1365 MHz all I did was move the power limit slider from MSI Afterburner by +10% I think that's the reason but I'm not sure if that is particularly safe.

To compensate with the voltage peak I set in WattMan the voltage to be in stages with the clock (rather than AUTO) hoping to override the voltage peak and so far it seems to have fixed the problem, I don't know yet it has just been 30 minutes now.

So the question here, should I keep WattMan overriding Afterburner's voltage settings (Though it is already disabled in Afterburner's settings) but still keeping the power limit at +10%? Is a 1.350v peak even a thing to worry about?

Temps are 60-65 if that helps.
 
Jul 28, 2019
41
0
40
1
I wouldn't worry about a 12mV overshoot.
I used DDU again but this time I installed AMD 19.5.2 driver instead of the Adrenalin 2020 one.

As of right now, after 2 days of testing, finally I haven't actually seen a voltage spike and I hope it remains that way.

I undervolted it again by -80mV (1070mV) and increased power limit by +10% and the clocks are very stable at 1365MHz no matter whats happening in the game, even in less heavier scenes and vsync on where I usually get 1200-ish staring at a wall, now it wont budge from 1365MHz not sure if thats a good thing tho because it never did that but I assume it is.

But the most important thing is is that spikes appear to be gone, looks like I'll stick with 19.5.2 instead.
 
Jul 28, 2019
41
0
40
1
Yes WattMan is better than Afterburner. You don't need both programs.

Make sure your WattMan profile is being applied on each cold boot. Windows flubs this up from time to time.
I noticed that when I add +10% power limit in Afterburner WattMan changes its power control automatically to +10%

Anyways I use Afterburner primarily for the fan curve, should I just use WattMan's fan curve and set power limit from there and just uninstall Afterburner all along?

EDIT: I tried working with WattMan's fan settings, I can say why people recommend Afterburner instead, now I don't know which one to use for which setting lol but definitely not WattMan for fan curve
 
Last edited:
Jul 28, 2019
41
0
40
1
WattMan has fewer points on the fan curve to adjust. Honestly, I've never seen the need to tinker with it. Card gets hot, fans go up, simple.

Have you tested lower voltages? I can do 1400MHz @ 1.15V on my RX480
I think you were the one who advised me to undervolt my GPU, I was planning to test it but I noticed that it never even reaches max core clock @ 1365 MHz even at stock voltage (1.187V-1.150V) on Unigine Superposition, just fluctuates around 1320 MHz so by adding a +10% powerlimit the clocks are stable and where they are supposed to be. I assume if I undervolt it it be even worse and will probably never even reach 1300 MHz but I could be wrong.

I use an aggressive fan curve because it's warm where I live so I keep it always above 60% speed when I'm playing, the stop-fan feature from Gigabyte is pleasantly quiet but tends to make the GPU +10°c hotter. noise is the least of my worries, as long as its cool it can be as loud as a tornado.
 
Last edited:
No, clocks aren't high because you're hitting power limit with the stock voltage, hence why increasing power limit (albeit small with +10%) improves the situation. By undervolting, you open up more power budget to hit/ sustain higher frequencies.

65C is very aggressive for an RX580. I doubt you'll find anyone that would disagree that anything 80C or less is perfectly safe. But, it's your choice how you want to balance noise and temps.
 
Last edited:
Reactions: xollextor
Jul 28, 2019
41
0
40
1
No, clocks aren't high because you're hitting power limit with the stock voltage, hence why increasing power limit (albeit small with +10%) improves the situation. By undervolting, you open up more power budget to hit/ sustain higher frequencies.

65C is very aggressive for an RX580. I doubt you'll find anyone that would disagree that anything 80C or less is perfectly safe. But, it's your choice how you want to balance noise and temps.
I followed your post and applied the exact voltages and reset the power limit back to default (+0%)

Core Clock
MHz / mv
600 / 820
900 / 870
1145 / 920
1215 / 945
1255 / 975
1300 / 1030
1365 / 1110
That's about 10mV above my average curve. So it should be stable. If not, try adding an extra 5mV to all values and test again.

Memory Clock = 2000MHz / 940mV, Memory Timing - Auto

Once you've confirmed the above to the stable, you should be able to enable "Memory Timing - Level 2" for an extra ~5% FPS boost.
And what can I say, I was completely wrong, it was totally the opposite of what I expected, it peaks at only 1.112V, power consumption and heat are noticeably lower while still hits 1365 MHz, thank you so much!

But I guess there is no harm in being overprotective over your hardware, I just get this kind of "paranoia" when I'm tinkering with valuable stuff on things I'm not well informed about, I asked this question before but I could use another answer for my convincing, I'm no tech savvy just a regular guy new to this technology, but can undervolting damage the GPU in any way? Because I will be keeping this GPU for 4+ years and I want it to last at least that.
 
Well, I already gave my answer to that in your other thread, so I'll let someone else chime in.

One thing to keep an eye on is that Windows borks up global WattMan settings from time to time on cold boots (startup after a full shut-down). It will result in some sort of voltage settings between your undervolt and stock voltage. Profile (game-specific) wattman settings don't seem to be affected by this. I've just gotten into the habit of checking before I play.
 
Jul 28, 2019
41
0
40
1
Well, I already gave my answer to that in your other thread, so I'll let someone else chime in.

One thing to keep an eye on is that Windows borks up global WattMan settings from time to time on cold boots (startup after a full shut-down). It will result in some sort of voltage settings between your undervolt and stock voltage. Profile (game-specific) wattman settings don't seem to be affected by this. I've just gotten into the habit of checking before I play.
I thought undervolting would have fixed the problem, I was wrong.

It is still peaking at insane voltages, this time I got it recorded to see when exactly it happens and how many times.



Happened while playing Fallout 4, though this happens at any time even at idle.

I tried using different monitoring software, CPUID HWMonitor, HWiNFO, and MSI Afterburner each at a time, same thing, I tried with no background application running, just the game and WattMan and HWMonitor, still happens.

EDIT: The original question was if these voltage spikes peaking at 1350mV was normal or just a misreading or poor VRMs
 
Last edited:
Tried this on my RX480 WattMan settings of 1305MHz @ 1030mV and logged GPUz @ 10Hz polling while playing Wolfenstein.

Frequency stayed rock solid at 1305MHz
Voltage (VDDC) stayed primarily between 1006mV and 1020mV with a few spikes to 1025mV.
 
Jul 28, 2019
41
0
40
1
Tried this on my RX480 WattMan settings of 1305MHz @ 1030mV and logged GPUz @ 10Hz polling while playing Wolfenstein.

Frequency stayed rock solid at 1305MHz
Voltage (VDDC) stayed primarily between 1006mV and 1020mV with a few spikes to 1025mV.
See, yours always stayed below the voltage that you have set, mine always stays above by a few milivolts and spikes way above 1300mV for absolutely no reason as it shows in the graph above.

Even when I just set the voltage to AUTO in Wattman it's not 1150mV as it should be from factory but instead at 1162mV and still spikes above 1300mV.

I found a work-around for the voltage spike, which is setting it with Afterburner and then resetting it, the spikes also happen with Afterburner's voltage control, but once you click the reset button it goes back to stock 1150mV magically and never spikes above 1200mV again. The only problem is that I have to do this every time I boot up my PC and I can't undervolt it otherwise the spikes will happen again.
 
Jul 28, 2019
41
0
40
1
That's very strange. The only thing I can offer is to try some different driver versions and/or ride it out through a couple more releases in case it's a wierd glitch.
Indeed, and quite annoying too, but after tinkering with the voltage through a complicated process with Afterburner and WattMan combined I managed to stop the spikes even when undervolted (yet), the only problem with it is I have to do this process everytime I boot up my PC like I mentioned above.

That said I believe it has absolutely nothing to do with the hardware, like you said I think it is very likely a driver bug that skyrockets the voltage for no reason, though it wasn't always like that I remember it being normal about 3 months ago.

I wanna try do a clean install for the driver and re-install it completely from scratch and leave no cache behind, do you know any safe way I can clean re-install GPU driver?
 
Shot in the dark - I've noticed that Windows Fast Boot borks up my WattMan settings on cold boot usually, but restarting fixes it. Try starting up your PC, then just restart. Don't do any software tinkering before the restart.
 
Jul 28, 2019
41
0
40
1
Shot in the dark - I've noticed that Windows Fast Boot borks up my WattMan settings on cold boot usually, but restarting fixes it. Try starting up your PC, then just restart. Don't do any software tinkering before the restart.
I reset all the settings and uninstalled Afterburner shut down the computer and started it up again and then restarted it, still not running at stock voltage (1162 instead of 1150 and spikes outrageously) so I guess I have to tinker with it everytime I boot up my pc to keep it at least at stock voltage, and by the way undervolting it after that process just brings back spikes again, so I will be forced to keep it at 1150mV with Afterburner to prevent spiking.

The only option I have is a clean install of the driver, if that wont work I don't know what will.
 
Jul 28, 2019
41
0
40
1
Shot in the dark - I've noticed that Windows Fast Boot borks up my WattMan settings on cold boot usually, but restarting fixes it. Try starting up your PC, then just restart. Don't do any software tinkering before the restart.
I found this on Reddit, the guy is having the same issue on his RX 570
https://www.reddit.com/r/Amd/comments/bsdrks/_/eomb6fq View: https://www.reddit.com/r/Amd/comments/bsdrks/rx_570_undervolting_and_some_weird_voltage_jumps/eomb6fq/?utm_source=share&utm_medium=web2x


I'm going to try this method this guy proposed and see if it may fix the issue, by the way since me and you both have about the same chip (480 and 580), this guy on reddit mentioned that the memory voltage should be the same as state 7 voltage, but 1070mV on memory doesn't seem right though?
 
Then that person doesn't know how the memory voltage setting works. (not many people do)

As the GPU core frequency decreases, it needs less voltage to keep it stable. Simple. However, unlike the GPU core that can change it's frequency (though it's 7 performance states), the VRAM always runs at a fixed speed under load (and a single lower speed when the card is idle). There is a necessary amount of voltage required to keep that VRAM stable also. The card always feeds VRAM the same voltage the core is requesting/getting (you can see this if you look at the VRAM Voltage Out VOUT/VID and compare that to the GPU Core Voltage VDDC in HWMonitor or HWInfo). The "Memory Voltage" setting acts as a lower limit for the GPU core voltage to prevent feeding too little voltage to the VRAM and causing it to become unstable/crash. The reason we need to test for a minimum Memory Voltage here is to make the most out of power saving features like FRTC/Chill/etc etc. If your Memory Voltage is set to the same value as the State 7 core voltage (or higher), the card may drop to lower frequencies, but the voltage will never go down. The more core States you can "open up" with a Memory Voltage that's lower than they are, the more flexibility you and/or your card has to adjust the power/heat/noise it's producing.

Here's my full write-up
 
Last edited:
Reactions: xollextor
Jul 28, 2019
41
0
40
1
Then that person doesn't know how the memory voltage setting works. (very few people do)

As the GPU core frequency decreases, it needs less voltage to keep it stable. Simple. However, unlike the GPU core that can change it's frequency (though it's 7 performance states), the VRAM always runs at a fixed speed under load (and a single lower speed when the card is idle). There is a necessary amount of voltage required to keep that VRAM stable also. The card always feeds VRAM the same voltage the core is requesting/getting (you can see this if you look at the VRAM Voltage Out VOUT/VID and compare that to the GPU Core Voltage VDDC in HWMonitor or HWInfo). The "Memory Voltage" setting acts as a lower limit for the GPU core voltage to prevent feeding too little voltage to the VRAM and causing it to become unstable/crash. The reason we need to test for a minimum Memory Voltage here is to make the most out of power saving features like FRTC/Chill/etc etc. If your Memory Voltage is set to the same value as the State 7 core voltage (or higher), the card may drop to lower frequencies, but the voltage will never go down. The more core States you can "open up" with a Memory Voltage that's lower than they are, the more flexibility you and/or your card has to adjust the power/heat/noise it's producing.

Here's my full write-up
Thanks for the clarification!

Now I uninstalled Afterburner and used only WattMan, set the voltage to 1070mV, so far so good, and frankly strange, it has only spiked at 1087mV well at least not 1300mV.

This is currently the last thing I can think of besides a clean install, if it somehow spikes randomly so high again I will try DDU.
 
Jul 28, 2019
41
0
40
1
Thanks for the clarification!

Now I uninstalled Afterburner and used only WattMan, set the voltage to 1070mV, so far so good, and frankly strange, it has only spiked at 1087mV well at least not 1300mV.

This is currently the last thing I can think of besides a clean install, if it somehow spikes randomly so high again I will try DDU.
Sad news, I did a clean install with DDU, and still automatic voltage isn't actually stock voltage 1150mV but instead its 1162mV, don't know about voltage spikes though

There is absolutely nothing I can do, I'll just wait until this card kills itself with this voltage towers and switch to nvidia for good, such a shame for a first GPU, but at least I know what to pick next time.
 
Jul 28, 2019
41
0
40
1
I wouldn't worry about a 12mV overshoot.
I used DDU again but this time I installed AMD 19.5.2 driver instead of the Adrenalin 2020 one.

As of right now, after 2 days of testing, finally I haven't actually seen a voltage spike and I hope it remains that way.

I undervolted it again by -80mV (1070mV) and increased power limit by +10% and the clocks are very stable at 1365MHz no matter whats happening in the game, even in less heavier scenes and vsync on where I usually get 1200-ish staring at a wall, now it wont budge from 1365MHz not sure if thats a good thing tho because it never did that but I assume it is.

But the most important thing is is that spikes appear to be gone, looks like I'll stick with 19.5.2 instead.
 
Jul 28, 2019
41
0
40
1
My bad. I meant to say what driver version I'm using. It's 19.9.2
Ty

Quite funny though, today I found out the GPU driver was 19.20 (for Ubuntu apparently) on my 64-bit Win10 OS even though I'm completely certain I installed 19.5.2

If that means stable clocks and voltages, hell I'll keep this one even on a different OS
 

ASK THE COMMUNITY

TRENDING THREADS