[SOLVED] RX 590 crashed multiple times and now shows "No Signal" on boot.

Apr 17, 2021
4
0
10
0
Hey all, new here. My friend’s PC has been having some issues since yesterday. I’ve spent some time at their place out of state for a little vacation, and I installed warzone on their computer since I play it often on my PC back home.

The first time I launched the game things went fine for one game, but when the second one was about to start, the screen flashed light blue and my display crashed, saying on the monitor “no input detected”. The computer was still running as if it was fine, but even after 30 minutes the display did not return. We decided to reboot the PC, then ran warzone on safe mode to see if it might have been some settings that made it crash, but it also resulted in the same crash a few minutes after booting the game again.

After rebooting twice, the third time I did not launch the game, but rather, did some research and found that users with the same GPU have similar issues with a recommended fix regarding turning the “Power Tuning” setting on and setting the power limit to 50% in the Radeon software. However, before I was able to do that, the screen flashed grey and crashed from just browsing and watching videos on the issue in Chrome. We tried rebooting the PC, but now the display does not come on at all on boot despite the rest of the computer looking and sounding fine.

Friends of ours recommended power cycling the PC, which did not do anything, and to check for any dust, shorts, corrosion, or blown fuses in the GPU. Their tower is really small and compact, and I could not remove the card from it, so a mutual friend who helped mine build the PC is gonna come over soon to help us remove it from the case to inspect it with us. On boot, the GPU fans are spinning though, just no output on the screen.

It’s been a bit frustrating trying to figure this out, especially since my friend has played other games like Genshin Impact and Final Fantasy XIV without this happening for many months prior. The PC is about 2 years old as of now. I also just learned that they never had the Radeon software to update the drivers, so it's been sitting on whatever the default is since installation. Does anyone have any idea what the issue could be? I've offered to help pay for a new GPU since I feel guilty and as the straw that broke the 590's back, but we don't want to replace it if the GPU isn't dead.

Specs:
MB: ASRock B450M Pro 4
RAM: GEIL EVO Potenza 16GB DDR4
CPU: AMD Ryzen 5 2600
GPU: Radeon RX 590 ARMOR 8GB
PSU: Insignia ATX 550W
Chassis: Rosewill FBM-X1 ATX Mini Tower
 

Ralston18

Titan
Moderator
Yes the PSU may well indeed be causing the problem.

The PSU provides three different voltages to various computer components and a problem with delivering any given voltage at the necessary power level can result in some computer components working and other components not to work. Generally LED's only indicate if power/voltage is present. Not necessary that that power/voltage is actually sufficient.

And there may be some threshold involved. All works well until wattage hits some value "X" and then fails or is otherwise unable to provide additional wattage.

That threshold may be dependent on multiple and/or varying conditions. And each crash may degrade the PSU even further and make matters worse.

FYI:

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

If one of your friends has a multi-meter and knows how to use it you can do some testing on the suspect PSU.

Not a full test because the PSU is not under load and load is actually more of the present concern.

However any PSU voltage(s) that are out of spec are a very good indication that the PSU is past its prime or ability to fully function.

As for "Get a better PSU....." ( per @drivinfast247 ) then you may wish to start thinking about doing so.

FYI:

Best Power Supplies of 2021 - Top PSUs for Gaming PCs | Tom's Hardware

The link provides both some underlying guidance as well as product recommendations.

Certainly go for more wattage.
 

Ralston18

Titan
Moderator
Are you able to test the GPU in another known working computer?

Look in Reliability History and Event Viewer for error codes, warnings, and informational events that correspond with the crashes or other issues while playing Warzone.

Could be a power related problem....

According to the following link the recommended PSU is 550 watts.

https://www.msi.com/Graphics-Card/Radeon-RX-590-ARMOR-8G-OC/Specification

Compare Warzone's hardware requirements with the hardware requirements for Genshin and Final Fantasy.

Even if the hardware specs are identical or close Warzone may simply have needed more power to play.

My thought is that that two year old 550 watt PSU is/was simply unable to meet the computer's (GPU) needs with respect to Warzone.

May have been close the edge so to speak and Warzone was just too much.

If possible try another known working higher wattage PSU.
 
Apr 17, 2021
4
0
10
0
Are you able to test the GPU in another known working computer?

Look in Reliability History and Event Viewer for error codes, warnings, and informational events that correspond with the crashes or other issues while playing Warzone.

Could be a power related problem....

According to the following link the recommended PSU is 550 watts.

https://www.msi.com/Graphics-Card/Radeon-RX-590-ARMOR-8G-OC/Specification

Compare Warzone's hardware requirements with the hardware requirements for Genshin and Final Fantasy.

Even if the hardware specs are identical or close Warzone may simply have needed more power to play.

My thought is that that two year old 550 watt PSU is/was simply unable to meet the computer's (GPU) needs with respect to Warzone.

May have been close the edge so to speak and Warzone was just too much.

If possible try another known working higher wattage PSU.
Hey there, firstly, thank you for the suggestions.

Unfortunately, my friend is the only one in the house with a desktop, so we can't test if the GPU is dead immediately. We're gonna call up some friends and see if we can come over with the GPU to test it in a different rig and see what happens.

Also, is it possible that the PSU is causing this even though the rest of the PC turns on like normal just without a display? I'm just asking since the third and final crash occurred without Warzone running at all, simply just using Chrome to do research on the issue.
 

Ralston18

Titan
Moderator
Yes the PSU may well indeed be causing the problem.

The PSU provides three different voltages to various computer components and a problem with delivering any given voltage at the necessary power level can result in some computer components working and other components not to work. Generally LED's only indicate if power/voltage is present. Not necessary that that power/voltage is actually sufficient.

And there may be some threshold involved. All works well until wattage hits some value "X" and then fails or is otherwise unable to provide additional wattage.

That threshold may be dependent on multiple and/or varying conditions. And each crash may degrade the PSU even further and make matters worse.

FYI:

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

If one of your friends has a multi-meter and knows how to use it you can do some testing on the suspect PSU.

Not a full test because the PSU is not under load and load is actually more of the present concern.

However any PSU voltage(s) that are out of spec are a very good indication that the PSU is past its prime or ability to fully function.

As for "Get a better PSU....." ( per @drivinfast247 ) then you may wish to start thinking about doing so.

FYI:

Best Power Supplies of 2021 - Top PSUs for Gaming PCs | Tom's Hardware

The link provides both some underlying guidance as well as product recommendations.

Certainly go for more wattage.
 
Apr 17, 2021
4
0
10
0
Yes the PSU may well indeed be causing the problem.

The PSU provides three different voltages to various computer components and a problem with delivering any given voltage at the necessary power level can result in some computer components working and other components not to work. Generally LED's only indicate if power/voltage is present. Not necessary that that power/voltage is actually sufficient.

And there may be some threshold involved. All works well until wattage hits some value "X" and then fails or is otherwise unable to provide additional wattage.

That threshold may be dependent on multiple and/or varying conditions. And each crash may degrade the PSU even further and make matters worse.

FYI:

https://www.lifewire.com/how-to-manually-test-a-power-supply-with-a-multimeter-2626158

If one of your friends has a multi-meter and knows how to use it you can do some testing on the suspect PSU.

Not a full test because the PSU is not under load and load is actually more of the present concern.

However any PSU voltage(s) that are out of spec are a very good indication that the PSU is past its prime or ability to fully function.

As for "Get a better PSU....." ( per @drivinfast247 ) then you may wish to start thinking about doing so.

FYI:

Best Power Supplies of 2021 - Top PSUs for Gaming PCs | Tom's Hardware

The link provides both some underlying guidance as well as product recommendations.

Certainly go for more wattage.
Again, thank you so much for this information. I had no idea that a PSU could cause so much trouble even when on the surface the rest of the computer seems like it works simply because the components turn on.

Luckily, Best Buy has a sale for an EVGA 600W PSU for $40, which is what I have in my personal rig, so I think I'm gonna buy this for her as well as a new mid tower case since the current tower she has is super small and horrible for airflow.

She talked to her coworker who helped her put the rig together, and he wants to take it so he can test the RX 590 in his rig to verify that it works and confirm that the PSU is the culprit. I'll update the thread with the results of all this when it's all set and done.

Thank you and @drivinfast247 for the help on troubleshooting this. You guys are super helpful!
 

bignastyid

Titan
Moderator
Again, thank you so much for this information. I had no idea that a PSU could cause so much trouble even when on the surface the rest of the computer seems like it works simply because the components turn on.

Luckily, Best Buy has a sale for an EVGA 600W PSU for $40, which is what I have in my personal rig, so I think I'm gonna buy this for her as well as a new mid tower case since the current tower she has is super small and horrible for airflow.

She talked to her coworker who helped her put the rig together, and he wants to take it so he can test the RX 590 in his rig to verify that it works and confirm that the PSU is the culprit. I'll update the thread with the results of all this when it's all set and done.

Thank you and @drivinfast247 for the help on troubleshooting this. You guys are super helpful!
I would not power a rx590 with that EVGA psu, it's mediocre at best(why it's only $40). Would be ok for on office system but does not belong in a gaming system with a gpu like the RX 590. In the current market you are looking at ~$80+ to get a decent PSU.
 

ASK THE COMMUNITY

TRENDING THREADS