Question Rx 6600 problem

Nov 16, 2022
3
0
10
0
Hello!
So I bought an PowerColor Fighter AMD RX6600 8GB and installed it in my PC.
My specs are: i5-8400, 8GB ram( 1 module ), 450W psu, pcie 3.0 MB, Win 11 pro
I used ddu first to get rid of nvidia drivers(previously had a 1050ti ) and then installed it and connected an 6 pin cable + an 2 pin cable.
The main problem is that i ran some benchmarks, played some games, but can't get any good performance. For example I get a maximum of 65*Celsius at 70%-100% and 40-50 FPS in 3dMark benchmakrs or games like elden ring, nfs heat, CoD at max/low grapichs.
It's kinda weird the fact that no matter what settings I choose, I almost get the same FPS( not even stable, i have lots of drops ).
I also tried using older drivers for the gpu, but the same things happens( currently on 22.11.1) . Also the wattage in the AMD adrenaline panel shows a maximum of 100W and it never crosses more than that.
Could it be psu not giving enough power? I am really confused and i can't find any solution, for the past 6 hours i have been trying to solve this.
PS: one thing to mention is that when i tried starting fortnite it said something like " amd driver known issues please update to the latest one"( but it is the last one)
Any answer is helpful!
 
Last edited:
Nov 16, 2022
3
0
10
0
What's the cpu usage per core?

What's the RAM usage? 8GB is not much and single channel kills the performance. What's the brand and model of the RAM?

yes i used ddu to remove nvidia drivers instead of the phsyx
CPU: 88%
GPU: 77%
VRAM: 50%
RAM:76%
FPS:44
tested in elden ring medium graphics
 

ASK THE COMMUNITY