Question Rx 6600 XT blackscreen

Mar 24, 2023
10
0
10
Please keep it to 1 thread.
So I recently changed from a 1060 to a rx 6600xt. And I have a problem. Sometimes I get the a black screen after the motherboard logo, (right when I should enter my pin) and the only way to fix it is to shut down pc from power button and start it again(sometimes I have to do this multiple times), there are also occasions when it start first try.
I tried ddu, reinstall windows, clear cmos, changed bios, turned fast startup on and off, changed graphics drivers.

Some things that I noticed is that my keyboard and mouse lights, when starting normally turn off for a brief second right after the mother board logo, and when I get the black screen they are turning off and on later than normal. Also if I restart my pc the black screen doesn't go away, but if I get it working and restart it works fine. The graphics card works fine no high Temps, no black-screen during gaming sessions, no crashes, and the performance is normal(3d mark score).

Another thing I noticed is that when I get the black screen the fans graphics card fans don't stop, and when it boots it does so my guess is that the graphics drivers don't start, but I don't understand why they work after I shut down the pc from the power button
 
Last edited:
Mar 23, 2023
23
4
15
My black-screen is doring startup,
Usually, if it happens during startup but doesn't happen during safe mode, it's a driver issue.
Are you using the AMD driver from AMD's website, or are you using the driver supplied by the maker of the AMD card?
And you're positive all of the nVidia driver and software were uninstalled?
 
Mar 24, 2023
10
0
10
Usually, if it happens during startup but doesn't happen during safe mode, it's a driver issue.
Are you using the AMD driver from AMD's website, or are you using the driver supplied by the maker of the AMD card?
And you're positive all of the nVidia driver and software were uninstalled?
I'm using amd drivers from amd website, and yes all nVidia drivers are gone bcs I installed a fresh windows.
 
Mar 24, 2023
10
0
10
So I recently changed from a 1060 to a rx 6600xt. And I have a problem. Sometimes I get the a black screen after the motherboard logo, (right when I should enter my pin) and the only way to fix it is to shut down pc from power button and start it again(sometimes I have to do this multiple times), there are also occasions when it start first try.
I tried ddu, reinstall windows, clear cmos, changed bios, turned fast startup on and off, changed graphics drivers.

Some things that I noticed is that my keyboard and mouse lights, when starting normally turn off for a brief second right after the mother board logo, and when I get the black screen they are turning off and on later than normal. Also if I restart my pc the black screen doesn't go away, but if I get it working and restart it works fine. The graphics card works fine no high Temps, no black-screen during gaming sessions, no crashes, and the performance is normal(3d mark score).

Another thing I noticed is that when I get the black screen the fans graphics card fans don't stop, and when it boots it does so my guess is that the graphics drivers don't start, but I don't understand why they work after I shut down the pc from the power button
 
Mar 24, 2023
10
0
10
What is the model number of the PSU? Corsair has good PSUs and not as good PSUs. Also, 450W most likely is way below what you need for the Rx 6600xt.
450 vs I guess it's not the PSU since it won't black-screen or crash when I'm gaming, also whenever the black screen happens(during startup) I can get it to boot in safe mode, so that's why I think its the drivers
 
Mar 24, 2023
10
0
10
So I recently changed from a 1060 to a rx 6600xt. And I have a problem. Sometimes I get the a black screen after the motherboard logo, (right when I should enter my pin) and the only way to fix it is to shut down pc from power button and start it again(sometimes I have to do this multiple times), there are also occasions when it start first try.
I tried ddu, reinstall windows, clear cmos, changed bios, turned fast startup on and off, changed graphics drivers.

Some things that I noticed is that my keyboard and mouse lights, when starting normally turn off for a brief second right after the mother board logo, and when I get the black screen they are turning off and on later than normal. Also if I restart my pc the black screen doesn't go away, but if I get it working and restart it works fine. The graphics card works fine no high Temps, no black-screen during gaming sessions, no crashes, and the performance is normal(3d mark score).

Another thing I noticed is that when I get the black screen the fans graphics card fans don't stop, and when it boots it does so my guess is that the graphics drivers don't start, but I don't understand why they work after I shut down the pc from the power button