[SOLVED] RX 6700 Low usage, Stuttering & Weird Behavior ?

Status
Not open for further replies.

basarbasar

Distinguished
Jan 27, 2015
70
2
18,535
I had to create a seperate thread for this.
Basically, i built a new pc, and tried some games that i thought would run well. In NFS Heat its unplayable, stutters everywhere. Tried Battlefield 5, 50-90 fps, stutters again. Then i figured i should record it with AMD Adrenaline and post it here, but after i pressed the record button my fps increased by 50. First pic is before i started recording.

06zTnyu.png


The game actually felt playable and the stutters were a lot less, but as soon as i stopped recording it went back. It still works every time. And i can't make any sense of it. Here are my specs:
Ryzen 5 5500
Adata XPG D30 3200Mhz 16GB
RX 6700 non-XT Pulse
Gigabyte B450M H UD
WD Green 480GB NVMe
NZXT C650B Bronze PSU

So far i've tried:
Fresh Windows install
DDU and reinstall,
DDU and old drivers,
Disable XMP

Any help appreciated!
 

Exploding PSU

Honorable
Jul 17, 2018
462
147
10,870
I'd like to point out that NFS Heat seems to hate certain PCs. I have a RX 6800XT and a Ryzen 5 2600 (granted, a lesser CPU, but still), and it stutters really bad even though CPU and GPU usage are far from 100% (or even 50% for that matter). It's unfortunate...

I managed to improve the NFS Heat FPS a bit by installing the UNITE mod, but I'm not sure why.
 

basarbasar

Distinguished
Jan 27, 2015
70
2
18,535
I'd like to point out that NFS Heat seems to hate certain PCs. I have a RX 6800XT and a Ryzen 5 2600 (granted, a lesser CPU, but still), and it stutters really bad even though CPU and GPU usage are far from 100% (or even 50% for that matter). It's unfortunate...

I managed to improve the NFS Heat FPS a bit by installing the UNITE mod, but I'm not sure why.
Yeah for that game i can't be sure its my pc, my brothers pc was stuttering like hell too. It's just luck it seems like.
 

zx128k

Reputable
throttlestop is good for the bitdefender performance issues (intel) but I would try disabling overlays or removing AMD Adrenaline software. Have a driver only install. Disable game bar etc. Check GPU-z for the gpus link speed.
 

basarbasar

Distinguished
Jan 27, 2015
70
2
18,535
throttlestop is good for the bitdefender performance issues (intel) but I would try disabling overlays or removing AMD Adrenaline software. Have a driver only install. Disable game bar etc. Check GPU-z for the gpus link speed.
Thanks, I'll do that once i get new RAM, returned the old ones because they gave errors in memtest... We'll see if that was the culprit.
 
Jan 14, 2023
17
11
15
Not really related but I would ditch RTSS/Afterburner and just use the AMD overlay. I ditched it a few years ago as I found I had way more stuttering with it installed/enabled.
 

basarbasar

Distinguished
Jan 27, 2015
70
2
18,535
FIXED!!! Seems like it was my ram, after replacing it performance in some games doubled. I can play BFV at 180-200 fps now. Thanks all!

Edit: By the way, the new ram is GSkill RipjawsV 16G 3200 MHz, the old one was ADATA XPG D30 16G 3200 MHz
 
Last edited:
Status
Not open for further replies.