RX Vega 64 Not Recognized Upon Initial Startup

jcpalerm

Honorable
Dec 3, 2013
5
0
10,510
0
My specs:

GPU: PowerColor RX Vega 64 Red Devil 8 GB
GPU Driver: 18.8.1 Adrenalin
CPU: i5-3570k - Turbo OC'd to 4.2 GHZ
Mobo: ASRock Z77 Extreme 4
RAM: Can't remember. 16 GB DDR3
SSD: 125 GB EVO
Monitor: ACER XF270HU
PSU: AX760 80+
OS: Windows 10 64-BIT

I used to have a GTX 980 when I got this new card. I uninstalled the drivers with DDU in safe mode and then installed the Radeon drivers.

Anyway, whenever I leave the PC off for more than 5 minutes and try to boot the RX Vega is not recognized. It lights up and the fans are on, but no image through the DP.

I have tried to plug in the HDMI (different panel) at this time too, but nothing. It seems as if the card is just not working.

But, if I turn off the computer and unplug and plug in the DP or HDMI and turn the PC on I get a fully functioning card. The card benchmarks just like an RX Vega, gets up to full loads and actually is usually bottle necked by the CPU (because it's in need of an upgrade). If I hit the reset button or restart the PC, the display works fine as long as the PC was just on. If I wait 5-10 minutes, the PC no longer recognizes the GPU without an unplug + restart.

This last point leads me to believe the issue is not a power one, my PSU should be enough to power this card. I should mention that the card sags a bit in the PCI-E slot, but I have an improvised brace in there to hold it up.

Some solutions I have already attempted:

1. Drivers: Updated, downgraded, uninstall, reinstall GPU drivers. I have tried several of AMD's drivers and bounced up from 18.8.1 to 18.5.1. The card runs on all of them after my little trick, but none of them alleviate the recognition problem.

2. Wires: Changed the wires, HDMI, DP2, etc. None of that fixes it.

3. Displays: Display doesn't matter, I have tried on TVs, monitors, etc.

4. Fresh windows install. Didn't help.

I was wondering if anyone had any insight into this issue as I try to re-seat the card, change PCI-E ports, etc. These seem unnecessary as the card works with a quick restart and unplug.

Any insight is appreciated, thanks for reading.
 

jcpalerm

Honorable
Dec 3, 2013
5
0
10,510
0
For google: This was an issue with a Windows settings. You have to go to Power Settings and Disable the PCI-E Power Management and Fast Boot.
 

ASK THE COMMUNITY