Question Rx470 fan spins but no display

zhfaiz93

Prominent
Oct 20, 2017
3
0
510
0
I just got RX470, Fan spins but no display AT ALL, neither detected in bios or Device Manager, However same gpu works on another mobo and same psu just fine,
I have tried uninstalling old drivers thats of 750Ti and 5450, But still Same, No display,
When i Mobo Port to get into bios i see no sign of gpu, the only thing i see is the intel hd multiplier in Northbridge setting,

Tried my old 5450 and Tx 750TI In my motherboard and both works just fine,
Its getting really confusing
This is what i found out
GPU IS WORKING
PSU IS WORKING
PCIE SLOT IN MY MOBO is Working
Updated latest mobo bios
Unistalled intel hd, radeon drivers, GeForce drivers
Somehow its just not working in my system

Motherboard - ECS H81H3-M4
CPU - PENTIUM G3240
CORSAIR VS450
8 GB RAM DDR3 1333 MHZ
2*HDD 5400 RPM
 

zhfaiz93

Prominent
Oct 20, 2017
3
0
510
0
I just got RX470, Fan spins but no display AT ALL, neither detected in bios or Device Manager, However same gpu works on another mobo and same psu just fine,
I have tried uninstalling old drivers thats of 750Ti and 5450, But still Same, No display,
When i Mobo Port to get into bios i see no sign of gpu, the only thing i see is the intel hd multiplier in Northbridge setting,

Tried my old 5450 and Tx 750TI In my motherboard and both works just fine,
Its getting really confusing
This is what i found out
GPU IS WORKING
PSU IS WORKING
PCIE SLOT IN MY MOBO is Working
Updated latest mobo bios
Unistalled intel hd, radeon drivers, GeForce drivers
Somehow its just not working in my system

Motherboard - ECS H81H3-M4
CPU - PENTIUM G3240
CORSAIR VS450
8 GB RAM DDR3 1333 MHZ
2*HDD 5400 RPM
 

ASK THE COMMUNITY

TRENDING THREADS