Question Rx480 no signal

May 13, 2019
2
0
10
0
Well finally talked myself into updating my graphics card drive. Which is always a bad idea something always goes wrong. Honestly dont even know why im here seeking help maybe im just frustrated and want to vent. Any who updated the drive did a clean install noe im stuck with no video signal on HDMI and dvi port nothing has worked i tried changing the pic slots removing my ram and changing it around. And nothing seems to work i dont even know what my options are i have no onboard video ports on my motherboard and the only cards i can use from friends are also rx480. Im really just fed up with technology at this point it all just seems to be useless junk that never works right. My only guess at this point is to buy a new card but i don't see how that will help consider my current situation. If i have to upgrade just to get pas this im just gona through it in the trash and be done with it all. Feel like this stuff is just designed to fail
 
Full specs?

If it's not even posting, then you may need updated motherboard BIOS. If it posts but doesn't display, try the card on your friends PC to rule out a faulty card.

Without knowing how old your PC is and the PSU wattage, it's hard to help.
 
May 13, 2019
2
0
10
0
Its a little old. My bios stopped getting updated in 2015. Ill take my card to a friends tomorrow and see how that goes. My cpu is amd fx 6300. Power supply is ancient dual rail 1000 watt. I clean the power supply every year. Hopping that might be the case I can live with upgrading that they are relatively cheap.
 

knickle

Distinguished
Jan 25, 2008
219
7
18,695
3
Maybe it was a type-o, but are you talking about the graphics "driver" from AMD? If so, that would only cause an issue inside Windows. When you power on the PC it should still post BIOS info. Have you tried to get into the BIOS (usually by pressing DEL)?
 

ASK THE COMMUNITY

TRENDING THREADS