Question RX570 card or driver issues

Fed_erico

Prominent
Jul 28, 2017
2
0
510
0
Hello everyone. Bought a brand new Sapphire RX570 mini ITX.
I install it, go to AMD site, download latest driver install goes well, reboot, all seems fine.
Start BF3 and I get a memory error:
View: https://imgur.com/a/z6YU0eI

I restart it and same error but this time even before entering a game.
I reboot pc, try again and same.
Check if card is plugged correctly, reposition it, its all fine. All power cables fine.
(My build is 600W Cougar VTX 80+ bronze PSU, G4560, MSI B250M bazooka and 8GB ddr4.)
So I decide to uninstall drivers and try with oldest one I could find on AMD site. I did a clean driver uninstall as suggested on AMDs site.
Try again and now pc doesnt boot, VGA motherboard leds ON. :eek:
Reboot and it works ... :rolleyes:
Launch BF3 and seems to work for a while. Then I get same error.
Since I read "memory" on the error message I try to run GIMP (pic editor software) and load a huge image. And... listen... it crashes! Looks like GPU is messing with my RAM. Bah... So I swap rams, try different slots but still get same error.
I uninstall AMD drivers and this time run windows with basic video drivers (no amd drivers isntalled) and everything runs just fine.
So... after messing for hours and hours with new gpu. I think that AMD drivers are causing memory issues and make every app trying to use lots of memory crash.

I've already tried many clean install of these drivers:
win10-64bit-radeon-software-adrenalin-edition-18.8.1-aug17.exe
win10-64Bit-Radeon-Software-Adrenalin-Edition-18.3.1-March5.exe
win10-64bit-radeon-software-adrenalin-2019-edition-19.2.2-feb12.exe

Don't know what to do. Please help me. I'm desperate.

Hello everyone! Please help me with this big issues.
Got a pc, G4560, 600W Bronze, 8Gb DDR4, MSI B250M Bazooka
Bought brand new RX570 Mini ITX Sapphire.
Installed drivers and at first I got stuck on boot with VGA mobo led on.... and it forced me to turn off UEFI and set legacy/uefi.
Then got another Booting error but apart of that now I can get to windows everytime.
Its' just it looks like AMD drivers messes up with my RAM or with GPU... sorry I don't get what's going on. I checked everything was plugged in properly, power cables are fine etc. I even swapped ram banks and repositioned GPU a couple of times. And run memtest86 (lol) and of course no errors found.

I can't play BF3 because of this error. Sometimes it launches, other it crashes while loading.
View: https://imgur.com/a/nxJkPMn


And on Gimp with high ram usage:
View: https://imgur.com/a/hxJZl6u

But if I run something like Kombustor to stress test GPU but not RAM/VRAM it runs just fine!

This did lots of clean driver reinstalls, old and news and none of them work. Same issues.

win10-64bit-radeon-software-adrenalin-2019-edition-19.2.2-feb12.exe
Win10-64Bit-Radeon-Software-Adrenalin-Edition-18.3.1-March5.exe
win10-64bit-radeon-software-adrenalin-edition-18.8.1-aug17.exe

The curious thing is If I just uninstall AMD drivers and run with windows basic video adapter, no crashes, all runs just fine. (but of course my GPU doesn't perform well). Hence I don't get if its a faulty GPU, bad drivers (all of them??), something incompatible in my build... or what?

Please help me.
 
Last edited:

dmorisette

Prominent
Dec 15, 2017
2
0
510
0
Do you have 4gb or 8 gb vram? What res are you playing at?
Try disabling AA totally, go into Wattman and create a manual fan curve (have 50% fan speed by 55 degrees or so then up steeply after that.) Apply and save that fan curve and re-apply it after each driver re-install.
When running Assassins Creed Odyssey I routinely have 7gb of system ram used with nothing else running. You may need to go to 16gb.
Start the AMD performance overlay (Ctrl/shift/O). It will show you how much ram and vram is used and card temp, speed, etc.
If you are close tp 8gb on ram usage, add some ram. If you are close on max vram usage go in to your game settings and reduce texture settings.
AMD needs to revise its' auto fan curve, or make it user adjustable imo.
 

Similar threads


ASK THE COMMUNITY