Question RX570 problem or cable problems not showing display?

ermdog2411

Distinguished
Sep 8, 2011
5
1
18,515
0
I bought a cheap gaming PC about 3 years ago with an RX570 already installed.

*Note- I have an old TV/PC monitor which requires a DVI-D to VGA adaptor. I only bring this up since one of the prongs on the adaptor seems more pushed down than the others. Otherwise, I've never touched or took apart the adaptor since I started using it years ago.

I thought my PC went to sleep as my monitor was black, but it would not pop up when trying to wake it. I thought maybe the vga cable was bad so I plugged another one into the adaptor and nothing. I restarted a few times and got it to display, but only for a few mins. Did a few more restarts and I got it to stay on for about a day then my PC froze and the screen went black. Have not been able to get it back on since. I noticed the gpu fans don't run on startup (they used to). Now they twitch for a sec when the PC is turned on and nothing.

I took a very old gpu card and put it in my new PC and got it to display (I did not need the DVI-D to VGA adaptor though). I'm leaning toward this being a GPU problem, but can't entirely rule out being the adaptor since it's the only other factor I can think of. Not even sure if a faulty adaptor can make your pc freeze.

I went thru the Event Planner and the errors that showed up around the time of failure was "The AMDRizenMasterDriverV17 service has failed to start due to the following error: The system cannot find the file specified"

Mind you, I noticed this error in previous months and nothing happened. I'm learning toward a GPU/driver problem but not 100% sure.

If anyone has any advice or recommendations, I'd be extremely thankful.
 
Last edited:
I bought a cheap gaming PC about 3 years ago with an RX570 already installed.

*Note- I have an old TV/PC monitor which requires a DVI-D to VGA adaptor. I only bring this up since one of the prongs on the adaptor seems more pushed down than the others. Otherwise, I've never touched or took apart the adaptor since I started using it years ago.

I thought my PC went to sleep as my monitor was black, but it would not pop up when trying to wake it. I thought maybe the vga cable was bad so I plugged another one into the adaptor and nothing. I restarted a few times and got it to display, but only for a few mins. Did a few more restarts and I got it to stay on for about a day then my PC froze and the screen went black. Have not been able to get it back on since. I noticed the gpu fans don't run on startup (they used to). Now they twitch for a sec when the PC is turned on and nothing.

I took a very old gpu card and put it in my new PC and got it to display (I did not need the DVI-D to VGA adaptor though). I'm leaning toward this being a GPU problem, but can't entirely rule out being the adaptor since it's the only other factor I can think of. Not even sure if a faulty adaptor can make your pc freeze.

I went thru the Event Planner and the errors that showed up around the time of failure was "The AMDRizenMasterDriverV17 service has failed to start due to the following error: The system cannot find the file specified"

Mind you, I noticed this error in previous months and nothing happened. I'm learning toward a GPU/driver problem but not 100% sure.

If anyone has any advice or recommendations, I'd be extremely thankful.
Have you made sure your chipset driver and all other important drivers are up to date and your bios
 

ASK THE COMMUNITY