Question RX580 fan problem. Drivers may be the issue

Nov 8, 2021
9
0
10
0
Hi team,

I have an XFX RX580 dual fan model that is currently having weird fan behavior. I have done several steps to try to fixing this and at this point I'm lost. I sent an email to XFX and they simply ignored me. Won't answer calls either.

My system specs:
i7-4771
16GB RAM
XFX RX580 8gb
Asus Maximux Hero VII
Windows 10 ver 20H2 (build 19042)

Basic problem: sometimes fans spin, sometimes they don't. Fan1 (closer to ports) works most of the time, Fan2 barely ever spins.
Let's get some things out of the way first:
  1. this is not a problem where temps are too low to have the fans spinning. I have stressed test the fans and when they don't want to spin. Lately, Fan2 does not even have red RGB light turned on (fan1 does have RGB light turned on).
  2. i have opened the cooling device, changed thermal paste, cleaned the fans manually and reconnected all fan related connectors.
  3. i tried my video card in another PC and both fans did not spin at startup.
  4. when I push Fan2 slightly with my finger Fan1 starts spinning for a couple of seconds and then stops.
Current state of problem:
At this point I was started to accept that the fan hardware was the problem.
After cleaning the card and closing everything back up I reinstalled the card and was not able to boot up windows. I started PC in safe mode deleted AMD drivers with DDU. Then I restarted and reinstalled latest drivers with AMD Adrenalin software. Somehow, Adrenalin was not opening BUT driver worked like a charm. Weirdly enough I wanted to stress test the card to check if the fans were working with high temps but Adrenalin refused to open. My problem now became how to open Adrenalin. After several reinstalls and following some guidance from some forum questions I followed these steps:
a) uninstall the driver from Device manager
b) uninstall Adrenalin from "add or remove programs"
c) delete "AMD" folder in C drive
d) reboot PC in safe mode and run DDU
e) reinstall Adrenalin and latest driver
After doing this it still did not work. At this point I was obviously starting to grow desperate. I found this great post discussing Adrenalin not opening.
https://community.amd.com/t5/drivers-software/amd-radeon-software-not-launching/td-p/166136/page/8

I followed the stop of going to C:\Users\<username>\AppData\Local\AMD and deleted the CN folder. I immediately opened the Adrenalin and TADA!!!! BOTH FANS WERE WORKING. Adrenalin still won't open. I tested the card for about 2 hours of gaming and they worked like a charm.
This morning I restarted the PC. Both fans spun at startup. 5 minutes later, FAN2 RGB turns off and stops spinning.
This indicates me that 1) fans do work, 2) this is likely a software problem.


Any thoughts?
 

Darkbreeze

Retired Mod
I'd actually be inclined to think it's more probably a hardware problem and that replacement of the fan or fans would be the more likely solution, however, it really could go either way and if you think it is software related I have to ask if you have tried using Afterburner to control the fan speed? At least to see if there is any change with a 3rd party solution in place.
 
Nov 8, 2021
9
0
10
0
Thanks Darkbreeze for the input.
I have tried Afterburner and I cannot manually control the fans. They stay off unless I manually spin Fan2 which will start Fan1. Fan2 will stay off even when doing this.
Is there any way to know for sure that this is a hardware problem? I'm just afraid of changing the fans and then continuing with the same problem :p

On a side note: it is difficult for me to find replacement fans for the card so I was thinking on doing a sort of DIY solution where I use case fans to cool the card down. I understand the fans will not have the temp sensor of the video card but I could just keep them steadily spinning at 70% which should cool the card well enough. Any recommendations on fans that move a good amount of air that could be used for this?

Best,
 
Nov 8, 2021
9
0
10
0
XFX RX580 8GB OC+
I'm thinking I should maybe format my PC, reset CMOS, maybe even flash the vga bios (which cares the hell out of me due to risk of bricking).
Any ideas?
 
Nov 8, 2021
9
0
10
0
On a sidenote I'm thinking of installing liquid cooling if I don't find a suitable solution. May need to post a separate topic on this since I'm a noob with liquid cooling. Already found a compatible block and radiator but I have questions regarding "where" exactly the video card block is hooked etc...
 

Tolis_GR

Admirable
If you forced the fan with your finger and it tried to spin then it looks like it's a low voltage power delivery issue. I would check the board ends to both fans to see any differences in voltage or resistance
 
Nov 8, 2021
9
0
10
0
Thanks for the idea Tolis. This brings a new possibility to the discussion. Both fans are connected to a single CRJ cable. Then the fan board will feed both fans. Should I test both fan connectors with a voltage meter?
 
Nov 8, 2021
9
0
10
0
Thanks again for the previous comments.
Hope both of you are able to find this thread again.
I did the following: 1)formatted HDD and reinstalled windows with an old version, 2) installed GPU-Z, Argus Monitor and latest Radeon Software.
Result: fans seems to work exactly like they should. Radeon Software still does not open.

I'm afraid the problem will happen again if I restart the PC. I have uploaded a video for you guys to take a look at.

My conclusions are:
  1. this is some serious driver/software problem.
  2. this is not a voltage or mechanical problem of the fans.
Here is the video:
View: https://www.youtube.com/watch?v=QzMwmFuNA5c


Any clues why Radeon not opening?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS