[SOLVED] RX580 - signal error - won't boot - x470 aorus 7

Jan 8, 2019
1
0
10
0
Heya,

I have the following:
x470 gigabyte gaming 7 wifi
9400 gigabyte (old gpu)
tx 650m corsair
2700x amd
16gb ram

None are OCed (not even the ram for testing purposes)

I tried upgrading to rx580 sapphire nitro+ 8gb today and it doesn't boot. I get sound errors and error codes.

What I've tried:
- updated the motherboard bios to the latest one (used to be 03/14/2018)
- changed the ram
- testing if I get voltage on the 6+2 x2 connectors from the PSU - I do get 12v on the 6 ones (apparently the other 2 are just ground)
- using the DVI port instead of the HDMI
- resetting the bios (multiple times)
- unplugging the battery and any source of power to the monitor and PC for 10 minutes
- using the pci x8 instead of x16

I don't have another PC to test it on, and I bought the card from newegg USA so it's hard to return it - hopefully it's not my fault.

Nothing seems to work. I can't get any signal on the screen whatsoever. After a while I get signal code 24 which "is not an error, it's shown on all boards after OS handover." - which is true because after I plugged in the old graphics card and while I'm writing this that's what's shown.

Video with what happens: https://www.youtube.com/watch?v=7wKqTxP68Ko
Post codes: http://download.gigabyte.eu/FileList/Manual/mb_manual_x470-aorus-gaming-7-wifi_1001_180628_e.pdf
Pictures with the connectors: https://imgur.com/a/S4pKqmc

The fans don't spin at all.

Regards,
Ioan.








 

Darkbreeze

Titan
Moderator
If you are not in the US, I would try contacting Sapphire directly. They might have distribution or warranty centers closer to you and might be able to avoid you having to pay a huge shipping fee to ship to the US as you would have to do with Newegg most likely. Actually, it might be worth contacting both of them to see what they say.

I don't see any way after all that you've already done AND given the hardware specifications that you have, that it can be anything other than a bad card. Unfortunately, Newegg and Amazon are well known for occasionally being of guilty of shipping cards that have already been returned once, and there is also always the possibility of a card that simply was faulty from the start or was damaged during shipping.
 

Darkbreeze

Titan
Moderator
If you are not in the US, I would try contacting Sapphire directly. They might have distribution or warranty centers closer to you and might be able to avoid you having to pay a huge shipping fee to ship to the US as you would have to do with Newegg most likely. Actually, it might be worth contacting both of them to see what they say.

I don't see any way after all that you've already done AND given the hardware specifications that you have, that it can be anything other than a bad card. Unfortunately, Newegg and Amazon are well known for occasionally being of guilty of shipping cards that have already been returned once, and there is also always the possibility of a card that simply was faulty from the start or was damaged during shipping.
 

ASK THE COMMUNITY

TRENDING THREADS