Question Ryzen 2600 + Gigabyte B450M - randomly not turning on / POST - RAM issue ?

Jul 31, 2022
2
0
10
0
Hi all

I have a Ryzen 2600 and a Gigabyte B450M S2H motherboard with Apacer RAM DDR4 2666 (2x 8GB sticks)

It originally had only one stick of 8GB RAM and all was working fine. I added another stick of the same brand and model and it will also POST and boot

However, randomly (say once or twice a week) the power will be on (e.g. fans spinning) but no POST beep and no display on screen. Resetting power doesn't work. I read online to try only one stick and so was messing with the RAM sticks. If I take out the RAM sticks and re-insert one stick it will work.

I thought maybe it wasn't compatible with 2 sticks, however even if I leave one stick in now the issue still happens once or twice a week. I have tried with both sticks, one stick (the original) and one stick (the new one) and in either slot in every configuration but still have the same problem. I have updated the BIOS and reset CMOS, even ran it without a CMOS battery.

Complete specs:
Gigabyte B450M S2H
Ryzen 2600
GTX 1660
256GB M.2 SSD,
250GB SATA SSD
Apacer RAM DDR4 2666 (2x 8GB sticks)
Corsair Bronze 750W PSU.


All parts are less than 18 months old
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Corsair Bronze 750W PSU.
Corsair is the brand of the unit, while Bronze is the advertised80+ efficiency rating and 750W is the advertised wattage of said unit. What is the model for said unit? How old is the PSU?

BIOS version for your motherboard and this moment of time? If you're having to reseat the ram, then it's probably an issue of grounding or static electricity build up on your system.
 
Jul 31, 2022
2
0
10
0
Thanks for your reply.

Power supply is a Corsair CX750M about 12-18 months old. BIOS version is F62

If it is static or electric build up, what do I do? Take out of case and rebuild?
 

ASK THE COMMUNITY