Question Ryzen 2600 overclock not downclocking

MxzsyXII

Commendable
Feb 6, 2017
38
4
1,535
0
I'm new to ryzen and overclocking, there are a few things that have me confused.

First thing first, the motherboard I'm using is the MSI B450 Tomahawk MAX on the latest bios (v34).


Now, down to the actual concerns.

I want to overclock my ryzen 2600 to just get the most out of it. I bought it used and the guy I bought it from told me he was able to get 4.2ghz but the voltage was a little too high for my taste, but it is possible.

I did take a shot and try to OC, I just went with a basic 4ghz clock and override 1.325v. This was just a first try and I just wanted to see if it did anything. First thing I noticed was that the clock speed doesnt downclock at idle, at all. Also the voltage doesnt go below the manual override I set, which idk is safe not or not. Will this degrade my cpu fast?

When I manually set the core speed, AMD cool n quiet disabled itself. Is this how its suppose to work?

Are there settings that I'm suppose to enable or configure to make the core downclock and voltage also drop when idle?

I tried manually enabling Cool n Quiet but then it asked which state, 0,1 or 2. This just confused me more. Can someone please explain this all to me? Is it ok for the core to stay at max speed and max voltage all the time even at idle?
 
When you overclock, you are setting fixed numbers. If you want it to boost as intended and change speeds at idle then put it a stock settings and leave it alone. The CPU will automatically boost based on temperature and load and downclock when not needed. If you want to overclock then your CPU and voltage are going to stay at what you set them at, that’s the point.
 
Check you power plan.
Right click on a blank area of you desktop
click on display
then click on power and sleep once on power and sleep.
click on additional settings in that section you should have
balacned , ryzen balanced and High performce.
selectect the plan you want.
I use High performance on my 2600x
beside each option you can click on change plan settings
the you can click on change advanced settings.
once the you can see the plan you have selected or even change plans for there.
now scoll down to Processor Power Management
click on min processor power state and see what it is sett at.
I f it is at 100% that is the reason your processor isn't down clocking at idle.
set it to 5%
click apply and ok
then check your clocks.
 

atljsf

Honorable
BANNED
if you want to overclock but also be able to see the cpu reduce core speed, lower temperature and do what it should do without overclocking, you can use ryzen master, enable the overclock when you want, then when you don't need the extra speed from the overclock, turn values to normal again, this way you get the maximum you want when you want and then the cpu performs as a normal not overclocked cpu
 

ASK THE COMMUNITY

TRENDING THREADS