[SOLVED] Ryzen 2600 upgrade no post

thisbeluis

Reputable
Aug 25, 2017
7
0
4,510
0
I got a ryzen 2600 today via Amazon to upgrade from ryzen 1200. After I put the new cpu in, the computer proceeds to power up and cycles a few times and stays at a blank screen. Monitor on, no power to my mouse and keyboard orher than the initial cycle. Fans stay spinning, no error code or anything.

Before I installed the new cpu I upgraded my bios to version 31 via gigabytes website anything past version 21 should be fine.

Specs.
Ryzen 1200
Gigabyte ab350m gaming 3
16 gigs ram 2400
Gtx 1660 super
450 power supply.

I've also tried a 750 power wat supply and same thing. Put everything back ( my original set up) and it started up fine, windows loaded up no issues.


Would this mean I got a faulty cpu? It did once load into bios but would just stay in the bios wouldn't load windows and almost made it seem like windows wasn't installed...which is obviously not right. I pretty much tried everything I can think of

Reset cmos
Tried one stick of ram
New power supply
Put everything back and it works fine. Only thing I can think of is the cpu?

But would a bad cpu load into bios? Even if it was just once?
 
Last edited by a moderator:

thisbeluis

Reputable
Aug 25, 2017
7
0
4,510
0
Did you update your chip set drivers prior to updating the BIOS (version F30 or later) as noted on the BIOS download page?



-Wolf sends
I did although to be fair I don't even know how to check current version other than someone suggesting cpu z but honestly that wasn't too helpful as it said i had rev. 00 not even sure what that means.

I even just re installed the chip set( did nothing to change what was displayed on cpuz s said rev 00 like it did previously)

So to my knowledge I have version 31 bios and the Chipset it requires.

Also after i tried installing the chipset again the second time, on initial boot got to bios screen look like it might load then got a blue screen saying pc needed repairs and it restarted and then back to no dispaly at all.
 

thisbeluis

Reputable
Aug 25, 2017
7
0
4,510
0
SOLVED. solved the issue by installing bios f20 the earliest bios that would recognize the ryzen 2600 and avoiding to do all the other requirements the newer bios asked. Works great!
 

ASK THE COMMUNITY

TRENDING THREADS