Question Ryzen 2700x Temp questions

Fornwith

Reputable
Feb 14, 2015
43
0
4,530
0
MOBO - B450 MSI Carbon pro
GPU: Vega 56 OC
Ram - 16GB DDR4 C15
NZXT Kraken X62 AIO cooler
PSU - Corsair 750x
Case - NZXT H500i
500GB M.2 SSD

Idle: 45 / 50c (+/- 5c)
Minor tasks: 55-60c (+/-5c)
Gaming 65-70c (+/-10c)
Streaming to Twitch (80-85c) (+/-5c) using OBS 900p 60fps medium

I let my CPU do its own thing with XFR and monitor temps through Ryzen Master. I've heard that at 85c is when it throttles but according to Ryzen master its 95c? I've OC'd my Vega 56, but that shouldn't necessarily affect temps that bad? I've been trying to get the best quality looking stream on OBS so I'm right around either 900p60fps fast or 720p 60fps medium. While streaming XFR underclocks itself to maybe 3.5 - 3.7Ghz. Otherwise if I'm just gaming its around 3.9-4Ghz I've never streamed before, this is the first rig I've built with help here about maybe a month ago. My cable management for a noob's first PC is done well, its not restricting airflow within the case.

I mean it is hot here in Hawaii roughly 30c and my room is a bit hot. I've got my tower on a stand so its not on my carpet. Im a bit lost on why temps are so high. Any help appreciated.
 
95c is shut off temperature, should never let it go anywhere close to it. Considering high environment temps, maybe you could restrict voltage to 1.4v or less or use negative offset. Frequency dropping on high loads may be result of lack of power from MB and it's VRM. b450 MBs are not exactly well suited for 8 core processors just for that reason.
 
Your temps are normal for a hot climate with ambient temps at 30C.
Normal temps are 10-15C above ambient room temperature at idle and 60-75C under load.
Reducing CPU Core Voltage in Bios can help keep temps down, so long as the system remains stable.
With your current setup and cooler you should be able to set Core voltage to 1.375V or less
 

Fornwith

Reputable
Feb 14, 2015
43
0
4,530
0
Uhhh guys. I think I broke something. -0.1 offset was working. I read somewhere of a guy doing -.2 so I tried it and now it wont even post to get into bios. You think the mobo or cpu gave out?
 

Fornwith

Reputable
Feb 14, 2015
43
0
4,530
0
Phew yes after a bit of googling and reading my manual my mobo has pins to short no switch. So settings are back to normal, but now one of my ram sticks arent showing. 16GB 2x8. Well it shows its in under memory, but when I go to the main page of bios it only shows 8192 which is only one stick.
 

Fornwith

Reputable
Feb 14, 2015
43
0
4,530
0
I just took out and reinserted the sticks and its fine now. Ahh I was panicking a bit. I dont have money to replace anything. But messing around is definitely fun. Woo haha.
 

Fornwith

Reputable
Feb 14, 2015
43
0
4,530
0
Thanks everyone. Everythings back to normal. I found my offset at -0.125 running smothly with way better temps. Huge difference in undervolting.
 

ASK THE COMMUNITY

TRENDING THREADS