Question Ryzen 3700x/B450-f/ - Very Odd Memory Voltage Issues

Dec 8, 2019
3
0
10
0
Hello folks,

So I just got some new memory for my rig. I was running with 32gb, HyperX Fury 2666mhz memory, 2x16gb,( https://www.hyperxgaming.com/us/memory/fury-ddr4 ). I need more for work, so I got another set of 32gb, the very same ones for a total of 4x16gb sticks.
It booted fine, but once into windows, I experienced a series of BSOD, each one with a different error message. I ran Windows Memory Diagnostic, riddled with errors. I thought it is maybe faulty ram, so I swapped out my old ram and only put in the new sticks. Everything runs smooth and fine.

For the record, I am running with Ryzen 7 3700x, on a ASUS ROG B450-F Gaming motherboard ( https://www.asus.com/Motherboards/ROG-STRIX-B450-F-GAMING/ ). I've never Overclocked anything, I just want a stable work machine.

From there, I did the following steps:
  • Individually use each memory stick one at a time in each slot. Each boot was stable. I have not run Memtest86 because I am fairly confident my ram is not the issue.
  • Went into the bios, reset all my settings there to defaults. I have a few Asus auto-tuner EZ-mode overclock settings enabled. Removed those and everything set to stock speeds.
  • The stock voltage for my ram is 1.2v. It had been set to 1.35v prior to resetting to defaults. Memory frequency prior to resetting to defaults : 2745Mhz, reset this to 2666.
  • I install the 4 sticks of ram again, but this time, it would not even boot. So I removed two, and it boots fine. Weird.
  • I set the DRAM voltage to 1.37 (.02v more than what it had been initially, before I reset to default values in the BIOS, since I was able to boot with all 4 sticks), put all 4 sticks back in.
  • After setting the DRAM Voltage to 1.37, I manage to boot just fine again. However, after running a Memtest64 memory stress test, I get many, many errors almost right away.
  • I go back into BIOS, decide to lower the frequency from 2666 to 2400. It boots, I run memtest64 stress test again for 1.5 hours, not a single error. Seems quite stable. I left it alone and went to take a shower, when I came back, the screen was black, and the mouse/keyboard unresponsive, but on. Unusual, weird, but upon rebooting, I ran the memtest64 for another 45 minutes and all was good. Not perfect, but better results than I had.
  • PS, I left the latency at default 16-18-18
TLDR; At stock memory settings of 2666mhz and 1.2v DRAM voltage, I can't boot with all 4 sticks. Only 2/4. Increasing voltage, and decreasing memory frequency gives me a stable boot.

Now I've installed ram many times over the years, but never have I experienced this before. I would not consider myself to be an experienced/advanced pc builder, but this still seems... odd to me?
I have never had to fiddle with DRAM voltages before, nor had to underclock the memory frequency at all. Am I doing something COMPLETELY wrong? I think my next step is to boot into Memtest86 and really figure out if it is faulty memory once and for all.

Thank you in advance for your time!
 
Last edited:

Darkbreeze

Titan
Moderator
First of all, mixing memory kits, even when they are the same model, has no guarantee of success. ONLY using a kit where ALL DIMMs come in the kit and have been tested together to "play nice", is ever guaranteed. And with four DIMMs, even then there can be problems but the chances of problems are definitely magnified when using two separate kits whether different or same kit model or not.

So a four DIMM kit is the only promising method and even then there COULD be issues, especially with higher speed kits.

That being said, I would take two of the sticks that came together, put them in the second and fourth slots over from the CPU socket, power on, go into the BIOS and enable the D.O.C.P profile. Save settings and exit BIOS. Shut down.

Install the other two sticks in the first and third DIMM slots. Power up, and see if the system will POST. I might take three successive attempts for the system to train the secondary and tertiary memory timings before it will POST successfully even if the XMP, A-XMP or DOCP profile has been enabled in the BIOS.

If it will still not play nice, start over, but after enabling the XMP/DOCP profile, but before you save settings and exit the BIOS, try bumping the SOC/DRAM voltage up by .020v. Then save settings, shut down, install the other pair of sticks and see if it will POST. If not, then you probably have four DIMMs that are simply not going to work together regardless that they all work separately and are the same model. From one production run to the next memory kits that carry the same part or model can have wildly different compositions. As seen here:

https://forums.tomshardware.com/threads/amd-ram-compatibility.3210050/#post-19785792


Or in some cases, they might just have minor differences that are enough to make them unfriendly playmates.
 

ASK THE COMMUNITY