Question Ryzen 3900X high idle CPU temperature

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
Hi - I have a Ryzen 3900X in an MSI X570 based motherboard running Win10x64 v1903.

I am trying to get to the lowest idle CPU temperature so that I can maximize my PC lifetime. I don't overclock my PCs - I'm perfectly happy with 24 threads at 3.80 GHz.

When I first built my PC a little over a month ago, the Vcore would fluctuate and drop down to 0.5 VDC and my idle CPU temperature was fairly stable around 33-34 DegC.

However, my CPU is now idling at around 38 DegC, and the Vcore never drops below 1.10 VDC.

How can I get back to the previous state, where the CPU/motherboard/Win10 would actively control the CPU Vcore and allow for lower idle temperatures?

Thanks,

AzJazz
 

MasterMadBones

Distinguished
Dec 26, 2012
333
32
18,890
47
There are some reports of higher CPU voltages and frequencies at idle with the 1.0.0.4B AGESA and sometimes 1.0.0.3ABBA as well. If you have updated your BIOS recently you can choose to roll back to the previous version, but I'm not familiar with MSI so I'm not sure whether that is possible. This bug doesn't seem to affect system stability, so you can safely choose to wait it out for a new BIOS.
 

dorsai

Honorable
Nov 23, 2013
695
75
11,290
75
When I first built my PC a little over a month ago, the Vcore would fluctuate and drop down to 0.5 VDC and my idle CPU temperature was fairly stable around 33-34 DegC.

However, my CPU is now idling at around 38 DegC, and the Vcore never drops below 1.10 VDC.
Use HWinfo64 to montior your PC sensors and see what it's telling you at idle...if it shows cpu activity above a couple hundred MHz at idle then you have a background process running. The MSI Dragon Center/Mystic Lights and the LED Keeper program it installs both caused problems for me and had to be uninstalled due to cpu usage and large memory leaks.
 

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
Have you checked if there is any background proccesses windows does not include in task manager, such as optimizing drives or updating applications?
I went into Task Manager and disabled almost all the Startup items I could reasonably get away with - I left my anti-virus and Windows Desktop Widgets (so I could monitor) running . It didn't seem to have any effect. I didn't disable any Services, though - I don't know if one of those could be the culprit.
There are some reports of higher CPU voltages and frequencies at idle with the 1.0.0.4B AGESA and sometimes 1.0.0.3ABBA as well. If you have updated your BIOS recently you can choose to roll back to the previous version, but I'm not familiar with MSI so I'm not sure whether that is possible. This bug doesn't seem to affect system stability, so you can safely choose to wait it out for a new BIOS.
I was running the 1.0.0.3ABBA-based MSI BIOS when everything was working, but also was running that same BIOS when it stopped working. I have updated my BIOS to the latest to see if it had any effect, but no luck there. I will check to see if reverting my MSI BIOS (safely!) is an option. I may try to go back to 1.0.0.3ABBA, since it was the last BIOS that did work.
Use HWinfo64 to montior your PC sensors and see what it's telling you at idle...if it shows cpu activity above a couple hundred MHz at idle then you have a background process running. The MSI Dragon Center/Mystic Lights and the LED Keeper program it installs both caused problems for me and had to be uninstalled due to cpu usage and large memory leaks.
@dorsai - When you say CPU activity above a couple hundred MHz at idle, what do you mean? I am running HWInfo64 to monitor my system. I see my CPU activity is usually less than 10% on all cores, 1%-2% total (based on the HWInfo desktop widget). Currently, MSI Dragon Center is installed - but disabled from startup on my system.
 

dorsai

Honorable
Nov 23, 2013
695
75
11,290
75
If you open HWinfo64 in "sensors-only" mode only you'll get a large panel with the feed from all your cpu and boards sensors.

One panel at the top will be titled "CPU [#0]: AMD Ryzen 9 3900" and it will display a lot of cpu info including a line titled "Core 0 T0 Effective Clock" and will repeat twice for every core 0-11 for you with the 3900x. That will show in almost real time all of your core clocks...on my 3600 it bounces constantly from almost 0 Mhz to 50ish Mhz on most cores with one or two going up to 100-200 Mhz while im typing this message...I have nothing else running besides this one browser window.

10% cpu activity on a 3900x is a lot of cpu power...basically a full core and a half or so running at 100%...which is a lot for idle. Typing this out my cpu usage is 0.3-0.5% total cpu usage.

I'd have Windows task manager open on the Processes tab side by side with HWinfo64 sensor panel and see if you can ID what program is causing the issue.
 

Dragos Manea

Admirable
AMD doe not recommends using anything else except ryzen master utility to monitor idle temperature, they explained that the cores are so sensitive to load that even an 3rd party monitoring software triggers them and they do not enter in the lowest energy mode. Uninstall anything that monitor cpu temperature and activity includding msi center and stuff like that and install ryzen master utility and check there temperatures.
 
Last edited:

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
If you open HWinfo64 in "sensors-only" mode only you'll get a large panel with the feed from all your cpu and boards sensors.

One panel at the top will be titled "CPU [#0]: AMD Ryzen 9 3900" and it will display a lot of cpu info including a line titled "Core 0 T0 Effective Clock" and will repeat twice for every core 0-11 for you with the 3900x. That will show in almost real time all of your core clocks...on my 3600 it bounces constantly from almost 0 Mhz to 50ish Mhz on most cores with one or two going up to 100-200 Mhz while im typing this message...I have nothing else running besides this one browser window.

10% cpu activity on a 3900x is a lot of cpu power...basically a full core and a half or so running at 100%...which is a lot for idle. Typing this out my cpu usage is 0.3-0.5% total cpu usage.

I'd have Windows task manager open on the Processes tab side by side with HWinfo64 sensor panel and see if you can ID what program is causing the issue.
Hi, dorsai (P.S. - Great user name!) - Thanks for the tip regarding HWInfo64 ... I do see a couple of threads running around 400 Hz or so pretty consistently. It looks like the WMI Provider Host and Windows Management Instrumentation Service are using about 1.5% CPU (combined) almost all the time. I don't know if WMI is the culprit, but maybe. I can't fully disable WMI - the WMI service won't terminate, and there are bad repercussions when I attempt to stop WMI. I don't remember if WMI was running when I saw better CPU temperatures, but possibly.

AzJazz
 

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
AMD doe not recommends using anything else except ryzen master utility to monitor idle temperature, they explained that the cores are so sensitive to load that even an 3rd party monitoring software triggers them and they do not enter in the lowest energy mode. Uninstall anything that monitor cpu temperature and activity includding msi center and stuff like that and install ryzen master utility and check there temperatures.
Hi, Dragos Manea - I followed your suggestion by temporarily uninstalling HWInfo64 and MSI Dragon Center, and it had no real effect on the CPU idle temperatures shown in Ryzen Master.

However, I found out what was causing my Vcore to be "stuck" around 1.100 VDC. The MSI Dragon Center Balanced Mode apparently programs the Vcore voltage to 1.10 V.

I have my system set to Eco Mode in Ryzen Master now, but it's not an improvement - it's probably worse.

It looks like Ryzen Master isn't reporting the actual CPU temperature. It definitely looks like the CPU temp is getting filtered in Ryzen Master display. The MSI motherboard has an LED display that shows the real-time CPU temperature (this display almost certainly driven by the BIOS, not any Windows software since it is a BIOS setting for what gets displayed), and it is more volatile than what is displayed in Ryzen Master. While Ryzen Master is showing a fairly solid CPU temp of around 37 DegC to 38 Deg C when idle, the MSI mobo LED display is showing a range of 36 - 44 DegC, where the CPU temp cycles through peaks every 7 seconds and then drops down to the lower CPU temp before peaking again. Previously (back when my CPU Temp was averaging around 34 DegC), the MSI mobo display didn't cycle through the peaks and was fairly stable at 34 DegC (which also matched the Ryzen Master display, which would make sense if the Ryzen Master CPU temp was filtered). Also, HWInfo64 CPU temperature tracks what is displayed by the MSI LED display, not what is displayed by Ryzen Master. With 2 independent sources of displayed CPU temp tracking each other but not tracking Ryzen Master - Ryzen Master would be the less reliable display.

I haven't found a setting in the Ryzen Master profiles that will get me back to a lower and more stable CPU temperature. I would have through that the Ryzen Master Eco Mode would get me even lower temps than MSI Dragon Center Balanced Mode, but that doesn't seem to be the case.

If you open HWinfo64 in "sensors-only" mode only you'll get a large panel with the feed from all your cpu and boards sensors.

One panel at the top will be titled "CPU [#0]: AMD Ryzen 9 3900" and it will display a lot of cpu info including a line titled "Core 0 T0 Effective Clock" and will repeat twice for every core 0-11 for you with the 3900x. That will show in almost real time all of your core clocks...on my 3600 it bounces constantly from almost 0 Mhz to 50ish Mhz on most cores with one or two going up to 100-200 Mhz while im typing this message...I have nothing else running besides this one browser window.
Hi, dorsai (P.S. - Great user name!) - Thanks for the tip regarding HWInfo64 ... I do see a couple of threads running around 400 Hz or so pretty consistently. It looks like the WMI Provider Host and Windows Management Instrumentation Service are using about 1.5% CPU (combined) almost all the time. I don't know if WMI is the culprit, but maybe. I can't fully disable WMI - the WMI service won't terminate, and there are bad repercussions when I attempt to stop WMI. I don't remember if WMI was running when I saw better CPU temperatures, but possibly.

AzJazz
 

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
OK ... So, I figured something out.

Ryzen Master appears to be modifying the motherboard's BIOS settings directly (which I expected).

Instead of using Ryzen Master cryptically change my BIOS, I decided to use my brain to cryptically change my BIOS. ;)

As I mentioned in the original posting, overclocking isn't a driving objective for me. I'm looking for long-term stability to get the most years out of my very high-end system. Getting an occasional 10% to 20% performance boost at the cost of a higher nominal idle temperature (which translates to a shorter lifespan) doesn't matter to me if I have a honkin' 24 threads of 3.8 GHz processing available.

So, I went into the BIOS >> Overclocking >> Advanced CPU Configuration, and I tried setting Core Performance Boost to Disabled. All the other Advanced CPU Configuration options (including Precision Boost Overdrive) are all set to Auto.

This is the option that fixed my problem.

Note: My Win10 Power Profile has always been set to Ryzen Balanced, though I don't know if that has an effect here.

After the BIOS change, my Vcore seems to be locked at a minimum of 1.100 VDC again, but my idle CPU temperature has dropped back down to a rock-solid 33-34 DegC without any fluctuations at all.

P.S. to Jon - I tried changing my Power Profile from Ryzen Balanced to Power Saver as you suggested, and my CPU clock speed dropped down to 2700 GHz and my CPU temperature dropped down to 32-33 DegC. However, that was a significant performance hit to get an extra 1-2 degC. So, I went back to Ryzen Balanced for my Win10 Power Profile.

Thanks guys for all the help!

AzJazz
 
Last edited:

jon96789

Upstanding
Aug 17, 2019
333
37
240
8
When you set the power options to power saver, it just drops the voltage to about 0.9V at idle which reduces the CPU temps. When the OS ramps up its power demand, the CPU will ramp up the speed up to its "rated" max. In my case, my 3900x seems to top off at about a steady 4 GHz on all cores. Some cores may peak at about 4.5 GHz but it cannot sustain that speed at all no matter what power option I set.

I set my CPU speed to 2.2 GHz at idle, and right now all cores are at that speed. My CPU temp is 36 degrees (it varies from 33-38 depending on ambient temps). I show one core peaked at 4.52 GHz, a few cores at 4.49 GHz and the rest peaked at 4.34 GHz.

The performance hit you get in Power Saver mode is when you have nothing taxing the CPU. Metaphorically, it's like a car engine on idle. It's not generating much horsepower. But when you need the power, the engine ramps up its speed. So you actually have a lower power demand which means you use less electricity.
 

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
Jon - What do you have for your Ryzen Master (or maybe BIOS settings)?

I tried setting my Power Profile to Power Saver (I haven't changed my BIOS / Ryzen Master yet), I can say that I currently see a lag when typing on the keyboard.
 

RodroX

Prominent
Aug 4, 2019
685
198
690
27
Ryzen Master for me is a half backed software, for monitoring is really lacking alot of useful options and values, and for overclocking it does it a little better. Even AMD told a well known Overclocker to use hwinfo instead.

I have a Ryzen 5 3600 with PB (Precision Boost) enable, not PBO (Precision Boost Overdrive), PBO is a diferent thing, when my CPU is idle (idle is when you let go your mouse and don't do anything with the PC) the vcore is around 0.9v and most cores enter sleep mode. BIOS version AGESA 1.0.0.4, but it was the same with the 1.0.0.3ABBA.

When you disable PB you basically locked your CPU Max clock at 3.8GHz which is the stock base clock (and in the process you also disable PBO and XFR). Your CPU will go down when idle, but it will never boost over those 3.8GHz again.

I would have tried something diferent, I would Disable - > PBO, XFR, PBO Scalar; and then leave PB enable to allow your CPU to automatically boost again, the way AMD design it to work.

Also when you say idle temps went up from ~34°C to 38°C (which is not a huge delta anyways to start with), Did you Room temp raise too, like, did the weather became more hot where you live ?
When you use an air cooler (like the box cooler Warith Prism or an Aftermarket one like Noctua NH-D15) the idle temps are conected to the room temps where the PC is. If the room gets warmer the CPU will idle at a higher temp.

Cheers
 
Last edited:
Reactions: AzJazz

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
Hi, Rodrox - Thanks for the suggestions! Are those BIOS settings (not RM settings)? I will give them a shot later tonight.

Yes, I am using a Noctua NH-D15, but my room temperature actually has gone down recently. As a result of the lower room temperature (and speeding up my case fans a little), my case has dropped from 34 DegC down to 30 DegC. However, my CPU temperature actually increased somewhere along this timeframe ... And, that's actually why I started this thread in the first place! I was expecting my CPU temperature to drop a little since the case temp dropped - but my CPU temp was rising.

Thanks,

AzJazz
 

jon96789

Upstanding
Aug 17, 2019
333
37
240
8
Jon - What do you have for your Ryzen Master (or maybe BIOS settings)?

I tried setting my Power Profile to Power Saver (I haven't changed my BIOS / Ryzen Master yet), I can say that I currently see a lag when typing on the keyboard.
I left my system BIOS at system defaults... No overclocking. In Ryzen Master, I set the system in Creator Mode and enabled PBO...
 
Reactions: AzJazz

RodroX

Prominent
Aug 4, 2019
685
198
690
27
Hi, Rodrox - Thanks for the suggestions! Are those BIOS settings (not RM settings)? I will give them a shot later tonight.

Yes, I am using a Noctua NH-D15, but my room temperature actually has gone down recently. As a result of the lower room temperature (and speeding up my case fans a little), my case has dropped from 34 DegC down to 30 DegC. However, my CPU temperature actually increased somewhere along this timeframe ... And, that's actually why I started this thread in the first place! I was expecting my CPU temperature to drop a little since the case temp dropped - but my CPU temp was rising.

Thanks,

AzJazz
I see, well NH-D15 is probably the best air tower cooler one can get. Remember we are talking about one 12 cores / 24 threads CPU beast with a 105W Base TDP (this is not your average Core i5 or Ryzen 5). So for me 34°~38°C is perfectly normal for idle. I think the load temps are more important for any CPU.

Cheers!
 

dorsai

Honorable
Nov 23, 2013
695
75
11,290
75
...
It looks like the WMI Provider Host and Windows Management Instrumentation Service are using about 1.5% CPU (combined) almost all the time.
...
...
So, I went into the BIOS >> Overclocking >> Advanced CPU Configuration, and I tried setting Core Performance Boost to Disabled. All the other Advanced CPU Configuration options (including Precision Boost Overdrive) are all set to Auto.
...

Is it possible you have not disabled all of the intrusive items under the Privacy tab under Windows Settings ? So the WMI Provider Host is running constantly ?

As far as disabling things in Bios like Core Performance Boost the problem there is you are hamstringing the systems performance...the Ryzen CPU's all have a bouncing frequency and so do Intels cpu's...it's the way modern cpu's are designed to provide the fastest performance possible.

A cpu with total usage hanging at 10% load all the time is an entirely different issue than the normal frequency bounce of a processor as it bursts to provide a snappy system.
 
Last edited:
Reactions: AzJazz

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
I left my system BIOS at system defaults... No overclocking. In Ryzen Master, I set the system in Creator Mode and enabled PBO...
Jon - Thank you very much! This is exactly what I was looking for, and my temperatures are actually better than my system was previously!

With the settings you suggested here + setting the Win10 Power Profile to Power Saver (tweaked slightly to improve performance on some of the sub-settings), my CPU Temp now idles rock-solid at 32 DegC when I'm not using it, and sits rock-solid at 33 DegC while I am doing minimal tasks like web browsing. I also have the benefit of getting a stable overclocking boost on multiple cores to 4150 - 4200 when needed. My CPU temp does pop up to 70 DegC and 60 DegC nominal during Prime95 stress testing, but I can live with that - I'm not sure how often that level of loading will actually happen during my real life usage. I tried running a few games and video encoding/decoding, and I didn't see my CPU get loaded very much at all.

I see, well NH-D15 is probably the best air tower cooler one can get. Remember we are talking about one 12 cores / 24 threads CPU beast with a 105W Base TDP (this is not your average Core i5 or Ryzen 5). So for me 34°~38°C is perfectly normal for idle. I think the load temps are more important for any CPU.

Cheers!
RodroX - My system was idling around 38 DegC when not in use while it previously idled at 34 DegC, which is what I was originally trying to repair with this post. I am now idling at 32 DegC with Jon's settings, which is even better than before. I haven't tried your suggested settings yet, but I will experiment with those today.

Is it possible you have not disabled all of the intrusive items under the Privacy tab under Windows Settings ? So the WMI Provider Host is running constantly ?
Dorsai - I originally disabled everything under Win10 Privacy Settings when I first installed my O/S, but it looks like MS added a few more items during an update. I now disabled everything under Privacy Settings, and hopefully it will reduce the intrusion of WMI. Also, I now have the 3900X back to providing CPU boosting and lower idle temperatures based on Jon's suggested settings (see above).
 
Reactions: dorsai and RodroX

AzJazz

Distinguished
Jul 4, 2009
33
5
18,535
0
Hmmm ... I have an update.

I found out that the Power Saver mode + PBO doesn't actually work very well in real usage (at least not on my PC).

I have seen an odd operational issue with this configuration - one that I have seen before, not long after I built my system. I did get rid of the problem with a configuration change (that I can't remember :().

What I am seeing is a somewhat random, massive slow-down in operation, and it may be related to file transfers - but not 100% sure about that.

There isn't anything odd or visible in Task Manager - such as odd CPU activity or Disk activity, but certain activities get much, much slower.

A case in point: When I start Daz Studio, it takes about 5 seconds to come up in RM Default mode with Win10 Power Profile = Ryzen Balanced (I'll call this: Normal Mode). When I use the above Power Saver + PBO settings, Daz3D Studio takes about 9 seconds to start. When I open a saved scene that I was working on in Normal Mode, it takes about 20 seconds to load. When I use the above Power Saver settings, the scene takes over 90 seconds to load (almost 5 x slower!).

Even worse, doing a program installation can takes about 30 seconds in Normal Mode took over 20 minutes to install in Power Saver Mode.

Again, I don't know why this is occurring - The CPU will quickly boost to 4200 MHz with the above Power Saver Mode, and my system seemed to run properly for the most part.

For now, I have gone back to setting the BIOS Core Performance Boost back to Disabled until I can figure this out.

AzJazz
 

ASK THE COMMUNITY

TRENDING THREADS