Ryzen 5 1500x B350 Tomahawk won't post, solid boot light

Sep 14, 2018
I finally got all the parts for this build about a month ago. When I put it all together it initially wouldn't post. I troubleshooted a lot and ruled out issues with the cpu, gpu, and ssd. I borrowed some memory from my brother that we know works, and it finally posted and booted. I installed windows on it, gave my brother his memory back, and then moved across the country with the pc. Now I ordered the same model of memory we used and installed it, and...no post.
I know the monitor and hdmi cord both work and I plugged the hdmi cord into the gpu, not the mobo. When I turn it on all the fans run, and the ez debug lights go on and off until it hits the boot light, which stays on. I plugged a keyboard into the usb and that lights up, but pressing delete/f10/f11/f12 doesn't work. I've tried letting it run for ten minutes or so and still nothing. I double checked all the connections and I still have this problem. I'm new at this so I would really appreciate some help.

CPU: Ryzen 5 1500x 3.5Ghz
Mobo: MSI B350 Tomahawk ATX AM4
Memory: Corsair Vengeance LPX 2x8 GB (slots 2 and 4) DDR4 3000Mhz
Storage: Seagate Barracuda 1TB HDD
GPU: EVGA GeForce GTX 760 4GB SC
Power supply unit: OCZ 600W


So, first thing I'd try is this.

With all of the hardware installed, as is, and with the power off, unplug the power cord from the PSU.

Remove the CMOS battery from the motherboard (Might require removing the GPU card on some motherboards) for about five minutes. During that time, press the power button for about thirty seconds. Next, double check that the RAM is FULLY seated, by removing it and reseating it until it clicks into place on both sides. Also, double check the manual to make absolutely certain you are installing them in the slots recommended in the manual's population guidelines.

Not sure what you mean by slots 2 and 4, because there are only slots A1, A2, B1 and B2. Memory should be installed as follows.

Reinstall the CMOS battery. Plug the PSU back in and power on. See if you get any love.

If no love, then try only one stick of RAM in the A2 slot. No love, try the B2 slot. Still no love, try the other module in each of those slots.

If not, then double check every connection and item covered here:


And if you still can't find the problem, then I'd remove the motherboard from the case and bench test it as follows: