[SOLVED] Ryzen 5 2600 and a 2070 Super having micro stutters in GTAV

Dec 3, 2020
10
0
10
0
Hi all, I have just upgraded from a XFX RX 590 Fatboy to a Gefore RTX 2070 Super Gaming OC 3x and have since been experiencing stutters in GTAV, I’m assuming it was because I had a 600 watt power supply and have recently ordered a new RM850x hoping this solves the problem but if not would anyone else know why I’m getting these stutters?
 
Dec 3, 2020
10
0
10
0
Welcome to the forums, newcomer!

What was the make and model of the older PSU and it's age? Did you use DDU to uninstall your GPU drivers prior to dropping in the RTX2070 Super?
My old PSU was an EVGA 600B and it was about 2 years old, and I did uninstall my drivers using DDU but I only did that after installing my new GPU. I installed all of the drivers for the new card and then couldn’t figure out why it wasn’t working so I wiped both the GPU (both AMD and Nvidia as my old card was AMD) and my CPU drivers and then reinstalling the newest ones to see if that would fix it which it did to some extent but the stutters are still here and I’m getting some odd performance in other games as well.
 
My old PSU was an EVGA 600B and it was about 2 years old, and I did uninstall my drivers using DDU but I only did that after installing my new GPU. I installed all of the drivers for the new card and then couldn’t figure out why it wasn’t working so I wiped both the GPU (both AMD and Nvidia as my old card was AMD) and my CPU drivers and then reinstalling the newest ones to see if that would fix it which it did to some extent but the stutters are still here and I’m getting some odd performance in other games as well.
Do you have more than one monitor?
 
Dec 3, 2020
10
0
10
0
Disable the connection to one of them and see if the micro stutter goes away. An update to Windows 10 coming soon, is suppose to finally fix the problem of having two or more monitors enabled and causing microstutter in games. I have the same problem on my system when I have my TV connected.
Ah okay I'll give it a go.
 
Dec 3, 2020
10
0
10
0
Ah okay I'll give it a go.
Disable the connection to one of them and see if the micro stutter goes away. An update to Windows 10 coming soon, is suppose to finally fix the problem of having two or more monitors enabled and causing microstutter in games. I have the same problem on my system when I have my TV connected.
It worked, woooo thanks for the hand mate and Thankyou all for helping me out :)
 

ASK THE COMMUNITY

TRENDING THREADS