[SOLVED] Ryzen 5 2600x doesn't go above 3.2ghz while at 99% or less, but goes up to 4ghz at 100%, but i want its max to be around 3.6ghz (base speed)

Jun 20, 2022
6
0
10
0
Hello, i have had my cpu for about a year now, in the beginning it was running on 3.2ghz, which was messing up some games etc so i decided to put it to 100% ghz, a while later i noticed that the temps were kinda high and just for the sake of it, i wanna keep them a little lover, so i tried setting the cpu to 99% and it dipped down to 3.12ghz max, i used powersheell to add max speed to battery settings and set it to 3500mhz, but the processor refuses to go above 3.12-20ghz, if i set it to 3600mhz, it goes up to 4ghz, so my question is, what am i doing wrong, since the processor only does 3.20 or 4ghz, no in between


When i stress test it on 3600mhz, the cpu speed goes up to 4ghz, 100%
When i stress test it on 3500mhz, the cpu speed goes up to 3.12ghz, 86%


would like to point out that when its 100% while gaming it goes up to 100%, but when on 99% it only goes up to 25-30% utilization
 
Last edited:
If you want to disable Turbo Boost:
  1. Open RegEdit and go to the location Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\be337238-0d82-4146-a960-4f3749d470c7
  2. Set "Attributes" to 2
  3. Open up Power Options -> Change Plan Settings -> Change advanced power settings -> Processor
  4. There should be an option called "Processor performance boost mode", set this to "Disabled"
This takes effect immediately.
 
If you want to disable Turbo Boost:
  1. Open RegEdit and go to the location Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\be337238-0d82-4146-a960-4f3749d470c7
  2. Set "Attributes" to 2
  3. Open up Power Options -> Change Plan Settings -> Change advanced power settings -> Processor
  4. There should be an option called "Processor performance boost mode", set this to "Disabled"
This takes effect immediately.
 
Jun 20, 2022
6
0
10
0
If you want to disable Turbo Boost:
  1. Open RegEdit and go to the location Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\54533251-82be-4824-96c1-47b60b740d00\be337238-0d82-4146-a960-4f3749d470c7
  2. Set "Attributes" to 2
  3. Open up Power Options -> Change Plan Settings -> Change advanced power settings -> Processor
  4. There should be an option called "Processor performance boost mode", set this to "Disabled"
This takes effect immediately.
Thank you so much! it's exactly what i've been struggling with and now its on 3.50ghz at 100%, i'll play around with the settings a little and maybe try any other boost modes but this is basically it!
 

ASK THE COMMUNITY

TRENDING THREADS