[SOLVED] Ryzen 5 2600x issues (heat, fan speed, sound, core clock, voltage)

Jan 9, 2019
6
0
10
1
Hi!

Here is my problem. I did find similar posts but don't think i found the answer/don't understand it. I have a brand new build with 2600x inside (specs later), which is my first and i count myself a beginner in the world of PC building, overclocking and BIOS navigation (and please treat me as such).

Problem is:
-The CPU core temperature is 40-50 °C when idle, reaching 83 °C during 3DMark tests. (room temperature is 25 °C at most)
-The CPU's core voltage reaching 1,40-1,44V idle and 1,46 during tests.
-The CPU's core clock speed is 2700-4200 MHz on idle and 4,1 MHz during tests.
-The CPU's fan speed is 1900-2300 rpm on idle, up to 2900 during tests. (both are loud)

While i know these all correlate and have to do with the xfr and precision boost stuff, it's still strange for me that at idle i can hear the fans revving and "noise polluting" my ears. (well it's bearable but seems abnormal)
As seen on the picture off CAM the heat fluctuations (and fan speed, clock speed, voltage changing with it) are strangely periodic, and cause the volume of the fan sound to mimic the periodicity.

This all might just be normal after all, but then the noise is still bothersome, considering it's a new PC and the CPU load is minimal. I didn't dare play around with fan curves and such in the BIOS, i don't know how safe that would be. On a side note i accidently touched the pre-applied thermal paste on the cooler, but a fingerprint was hardly even visible, and i wouldn't think that could be reason for all these things.


Any thoughts and help would be appreciated. If any information is missing just ask and i'll provide.

Thanks,
Quirius


Pictures:
https://imgur.com/a/V23DVQb

Specs
CPU: AMD Ryzen 5 2600x with stock Wraith Spire cooler
MB: Gigabyte B450 Aorus Pro
GPU: Sapphire Radeon RX 590 SE
RAM: 2x8GB Kingston HyperX Predator 3200MHz
SSD: 500GB WD Blue NAND SATA III
PSU: Bitfenix Whisper M 750W
Case: Deepcool Tesseract SW with 1 intake and 1 exhaust fan.


PS: I forgot to mention the only thing i did in BIOS is enabling XMP Profile 1. Thought might be relevant.
 

hussainali88

Reputable
Feb 19, 2015
34
0
4,560
9
Voltage is too high, make sure your bios is updated to latest version and if it is not solving the problem then try and set the cpu voltage to 1.275 and test. if the system crashed then increase it to 1.3v .
 
Jan 9, 2019
6
0
10
1
The BIOS I didn't touch yet, because i read all over the internet that pinnacle ridge and B450 go hand in hand without doing anything, but i'll look it up! Thank you so far!
 
Jan 9, 2019
6
0
10
1
So after some tinkering with fan curves and befriending Ryzen Master I got a partial solution. In the BIOS I set the fan's curve so that it is constant (35%) up until 72 degrees celsius, when it shifts to maximum. This way it is silent when idle and only revs up while under pressure. I might still have to adjust it in order to not fluctuate when gaming.

In Ryzen Master i played a bit with overclocking and downclocking and figured that 1.45V and the like (once 1.49V also) are because of Precision Boost and only appear when only 1 or 2 cores are overclocked for background calculations. When all clocks are pushed all cores go up to <4.3GHz and the voltage goes down to ~1.35. According to other internet people this is perfectly normal.

Only other issue remaining is the temperature. It still goes up by itself even when idle, only now it stops at around 50 degrees because of the constant fan curve at that temp.

I would consider that normal in the case i was playing and pressuring the CPU, but this also happens when idle. I didnt dare try out how hot it would get if i capped the fan speed lower.

Ps.: BIOS updated to the latest version without issue, but no changes happened.
 
Mar 5, 2019
1
0
10
0
Hmm I have not overclocked my 2600x yet I only change the fan curve using the wraith spire cooler and the temps are very good now with all cores at 3.6 ghz.
According to the hardware monitor in the sapphire trixx software the highest cpu temp ive gotten is 62 degrees and lowest at 36 degrees celsius with 42\52 being average when I was playing apex legends on high settings.
But according to CPUID hwmonitor it always shows 10 degrees more?
Having the fan speed around 30 percent at 40 degrees, 60 percent at 50 degrees, 70 percent at 60 degrees and 100 percent at 70 degrees works fine for me with that curve but does not sound that loud in my case either and im still using my NZXT H2 case =)
 
Mar 14, 2019
2
0
10
1
I have the same issue, I have the ryzen 5 2600x, and am using the stock cooler. The stock fan gets really loud, sounding like a jet engine while playing any games basically. And because of the ryzen boost, it just spikes up in heat and sound randomly. With ryzen master and HW Info, and CAM, my CPU starts at 52 degrees C, and then goes up until like 79 degrees and sometimes spikes to 80+ degrees while gaming. And the fan gets really loud, spinning at over 1800 RPM sometimes to 2200 RPM. I also have seen the voltage go above 1.4V, almost to 1.5V when just idling and looking at the ryzen master software and HW Info(it spikes randomly from 0.8 Volts). My BIOS is latest Version for my mother board, and I haven't tampered with any settings, except I had to change the boot order and put my SSD first.

The stock fan makes almost a buzzing sound even at lower RPMs, but my CPU fan always seems to stay above 1400 RPM. I can hear the sound over music and playing games with headphones on...
 

ASK THE COMMUNITY

TRENDING THREADS