Question Ryzen 5 3600 Boot looping after CPU upgrade

mark520fay35

Prominent
Nov 10, 2018
42
5
535
0
Hi. Before I start, here are my specs:
Ryzen 5 2600 (Upgrading to 3600)
Asrock phantom gaming 4 x570
G.skill sniper X 8gb (only 8gb for breadboarding)
Samsung 860 Evo 500gb

Recently, I decided to upgrade my current 2600 processor to a ryzen 5 3600 processor.
But after switching to the new processor, I would just see an infinite loop, and Windows would only boot into safe mode.
I can almost confirm that this is a Windows issue, as I ran a clean install on a spare SSD, and Windows 1909 worked just fine.
Anytime that I switch back to the Ryzen 5 2600 with the drive I'm currently using, the OS would boot again.

Since I concluded it to be a Windows issue, I ran a repair-install, and upgrade from 1803 to 1909.
It appears that windows could automatically prepare the hardware for booting, but as I aforementioned, windows would only boot into safe mode after switching the processor.

I've tried updating BIOS, changing RAM slots, reset CMOS, and did an OS overhaul. I'm not as experienced with diagnostics from boot logs and driver issues. Is there any possibility that I could diagnose the problem from a software perspective? Any help would be appreciated, thanks!

Edit: how I would identify it as boot looping is during the spiny circle startup animation.
There would be a very subtle “lag.”
Slight pauses (3 times a second) that’s noticeable. I’d assume that some kind of program is restarting repeatedly.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS