Question ryzen 5 3600 permanently in 4.2ghz boost

Nov 23, 2018
15
2
15
0
Hello,
i build a new pc and noticed that my ryzen 5 3600 is always in turbo even when i'm just browsing.
Disabling precision boost overdrive didnt help, i also tried turning off core performance boost, but that causes my cpu to always stay on 3.6ghz and never downclocking or boosting. Having my energy plan on ryzen balanced keeps my cpu always on 4.2, but according to hwinfo when i put the power plan on balanced (the windows default) then my clocks jump from 4.2 to ~2.8-3.5ghz EVERY SECOND.
I also think that being always in turbo causes my high temps, i have like ~42°C when just browsing. (cpu cooler: scythe mugen 5)
My old i5 6500 was around 30°C all the time with a crappy deepcool cooler.

So what can i do to lower temps and especially fixing that perma boost problem?

my hardware:
r5 3600
msi b450 tomahawk
3000mhz cl15 crucial ballistix
rx 580 8gb

thanks in advance
 
Reactions: zahid0406
Nov 23, 2018
15
2
15
0
well, why doesnt it downclock? and my cooler is beefy so im not really sure if 42c is fine. I think 42c are caused by being in boost all the time. if it would downclock normally my average temps would be 35c or even less.
 
Reactions: zahid0406

CosmicDance

Proper
Jun 11, 2019
157
36
120
2
Changing your Windows Power Plan to Energy Saver will limit your CPU speed and voltage.
My Ryzen 2700X peaks at 2200 MHZ in this mode.
You might want to change the advanced settings of the plan as it turns off your hdd, monitor etc after a short time to save energy further.
 
Nov 23, 2018
15
2
15
0
Changing your Windows Power Plan to Energy Saver will limit your CPU speed and voltage.
My Ryzen 2700X peaks at 2200 MHZ in this mode.
You might want to change the advanced settings of the plan as it turns off your hdd, monitor etc after a short time to save energy further.
yeah, but thats not my goal. i just want it to downclock when not in games. mine also stays at 2.2ghz in the energy saver mode.
Like whats the point of being in 4.2ghz turbo when watching a youtube video lol.
 
Nov 23, 2018
15
2
15
0
Go into the power plan
Processor power management
Minimum power state set to 5%
Having my energy plan on ryzen balanced keeps my cpu always on 4.2, but according to hwinfo when i put the power plan on balanced (the windows default) then my clocks jump from 4.2 to ~2.8-3.5ghz EVERY SECOND. and yeah i have it on 5% and im using that balanced mode right now
 
Nov 23, 2018
15
2
15
0
You don’t need to use power save mode, just try balanced.
Having my energy plan on ryzen balanced keeps my cpu always on 4.2, but according to hwinfo when i put the power plan on balanced (the windows default) then my clocks jump from 4.2 to ~2.8-3.5ghz EVERY SECOND.
 

TechyInAZ

Titan
Moderator
Your way way way overthinking this OP.

Leave the CPU as is. It's supposed to turbo even in lighter applications. Going to power saver mode will do absolutely nothing to save you extra power, heat and reliability with just clock speed and voltage. Because running a lighter application won't hit your CPU with enough load to make it worthwhile, no matter if your at 5ghz or 2.2ghz.
 
Reactions: Phaaze88

MasterMadBones

Honorable
Dec 26, 2012
297
12
10,865
42
This is exactly why I'm not a fan of the Ryzen Balanced power plan. It boosts all cores unnecessarily, increasing power consumption and potenially lowering the maximum boost frequency.

The way you're describing the CPU's behavior under the regular Balanced power plan sounds normal. The boost algorithm opportunistically increases the frequency of each core individually, based on a number of factors including demand. If there is no demand for high clocks, the CPU will go down to a lower power state. Windows also takes the average of all core clocks, so it's likely that one or two cores are clocking up to (near) full boost while the others are sitting at 2-2.5 GHz or so.

Keep an eye out for BIOS updates though. There are reports that there is a bug in AMD's release firmware that is causing Ryzen 3000 CPUs to be unable to reach their peak clock speeds.
 
Nov 23, 2018
15
2
15
0
This is exactly why I'm not a fan of the Ryzen Balanced power plan. It boosts all cores unnecessarily, increasing power consumption and potenially lowering the maximum boost frequency.

The way you're describing the CPU's behavior under the regular Balanced power plan sounds normal. The boost algorithm opportunistically increases the frequency of each core individually, based on a number of factors including demand. If there is no demand for high clocks, the CPU will go down to a lower power state. Windows also takes the average of all core clocks, so it's likely that one or two cores are clocking up to (near) full boost while the others are sitting at 2-2.5 GHz or so.

Keep an eye out for BIOS updates though. There are reports that there is a bug in AMD's release firmware that is causing Ryzen 3000 CPUs to be unable to reach their peak clock speeds.
im afraid that the beta bios that msi released will be the final bios on my mobo. Because with 16mb the space on the mobo is limited, according to msi. Thats why they gonna re-release a bunch of b350/b450 boards with incread memory to get a "better bios"
 

MasterMadBones

Honorable
Dec 26, 2012
297
12
10,865
42
You'll be sure to see some BIOS updates. Because the AGESA code for the 3600 is already installed, the storage space has already been taken. It just needs to be overwritten. BIOS storage only really becomes an issue when adding new features or new CPUs to the support list. This is just a bug fix.

Besides, the A320 boards that don't support Ryzen 3000 all have 8MB of storage. That means they still support 25-30 SKUs, which is around 350kB per SKU without features taken into account. At this rate, X570 should have space for around 50 SKUs, 35 of which are taken at this point.
 
Aug 18, 2019
1
1
15
0
Go into the power plan
Processor power management
Minimum power state set to 5%
This is what should solve the problem. I have ryzen 5 2600x and I was not having this problem until I read this article. I recently changed power plan and other settings after installing a be quiet! Dark Rock 4. Your new cooler allows your cpu to overclock itself always and at 42 degrees it is normal during overclock without load. If you go to power plan and change minimum to 5% it will fix the setting that has been changed.

Your CPU will still jump periodically with low or no load and there is nothing to do or worry about. It is normal operation even with stock cooler.
 
Reactions: DMAN999

DMAN999

Commendable
Apr 17, 2019
1,418
362
1,240
48
My 3600 stands at 4ghz when I am just browsing the net.
Did yo update the Chipset Drivers and use the Ryzen Balanced Power Plan from the article I linked to in my last post???
If not, try that and set the Minimum Processor State between 5% and 20% in the Advanced Options of the Ryzen Balanced Power Plan.
View: https://imgur.com/NUkwmzk

That will allow your CPU to downclock when possible.
 
Aug 4, 2019
16
0
10
0
Did yo update the Chipset Drivers and use the Ryzen Balanced Power Plan from the article I linked to in my last post???
If not, try that and set the Minimum Processor State between 5% and 20% in the Advanced Options of the Ryzen Balanced Power Plan.
View: https://imgur.com/NUkwmzk

That will allow your CPU to downclock when possible.
Yes I have downloaded the chipster drivers and it's on balanced power plan. I checked it like you posted in the pic, minimum cpu state is set at 99%... that is deafult as I never touched it. Is it supposed to be like that? What will be the diffrence if I put it to 10%? Seems heavy...
 
Aug 4, 2019
16
0
10
0
Change it to 5% or 10% so that your CPU can downclock at idle.
With it set at 99% it will never downclock at idle.
Why would AMD set it to 99%?

Anyhow I changed it to 20%, But I still dont really understand it. At first it dropped down to 3.6ghz~, now it's back on 4ghz and it still stands at 20% minimum. What's the deal with that stuff?
 

ASK THE COMMUNITY

TRENDING THREADS