[SOLVED] Ryzen 5 3600x not working on msi B450 Gaming plus MAX

Nov 11, 2019
5
0
10
0
Hi,
This is my first post so I wish I'm not making errors.

Components:
CPU: ryzen 5 3600x
Motherboard: msi B450 Gaming Plus MAX
RAM: 2x8 Gb Vengeance LPX 3000MHz
VGA: gigabyte gtx 1070Ti
SSD: crucial MX 500 250Gb
PSU: EVGA 650 W

As I said in the title, I have a ryzen 3600x which doesn't work and I don't know why!
When I try to turn on the computer, ez debug led turns on for CPU and it can't boot or, when it works it stays on for about 5 min and then, with no warning signal, it crashes.
I already updated BIOS to the latest version (on a motherboard that should be compatible out of the box), I checked every cable connection, disconnected everything is not necessary from the motherboard, put just one ram and so on... I really don't know what to do.
Thanks for your help
 

Wolfshadw

Titan
Moderator
thank you for your answer!
i checked multiple times CPU's pins (even when i RMAed a motherboard i thought was the problem, a msi B450M gaming plus).
I tried every release and today, before updating to H51, i tried to turn it on again with H4 but it wasn't even able to boot one time, so i updated and the situation didn't change...
Yes i used DIMMA2.
Yes i tested both of them individually.
PSU i'm using it's EVGA SuperNOVA 650 G2 Gold 80+ model Number 220-G2-0650-Y2 .
RAM i'm using it's Corsair Vengeance ddr4 3000Mhz 2x8Gb c15 k2 model Number CMK16GX4M2B3000C15
thanks! :)
Thanks

Memory QVL States:
CMK16GX4M2B3000C15 ver5.30
CMK16GX4M2B3000C15 ver3.32

Your RAM:
CMK16GX4M2B3000C15

I'd say it should be compatible.

Power supply appears to be very well rated, but even top-name models can fail. I wouldn't expect this to be the issue, but would it be possible to test the power supply in another similar system?

-Wolf sends
 

Wolfshadw

Titan
Moderator
Have you checked the CPU for bent pins?
When you updated the BIOS, did you use the Beta Version (H51) or the latest stable release (H4)?
When you installed just a single RAM module, did you use RAM slot DIMMA2?
Did you test each RAM Module, individually, in that slot?
Details are everything. WHICH EVGA 650w power supply did you purchase/are using? Please include the model number.
Details are everything. WHICH Corsair Vengeance LPX DDR4-3000 RAM are you using? Please include the model number.

-Wolf sends
 

Giannis_Mag

Commendable
May 24, 2017
84
9
1,545
4
Try to find another motherboard to test the cpu.Rarely the problem comes from cpu. Every component seems ok and it should work. Also check if the cpu cooler is well conected and sits tight on the cpu.
 

yourilevoye

Commendable
Jan 6, 2017
203
7
1,715
20
Hey! I also recently installed Ryzen 3rd gen on a B450 MSI board.

I assume you made use of the bios flas to get the compatable bios version on it?
If so, you have to change the bios file to MSI.rom before trying to flash it to the motherboard.
Also, sometimes it takes multiple tries. Took me 3 times.
 

Wolfshadw

Titan
Moderator
Hey! I also recently installed Ryzen 3rd gen on a B450 MSI board.

I assume you made use of the bios flas to get the compatable bios version on it?
If so, you have to change the bios file to MSI.rom before trying to flash it to the motherboard.
Also, sometimes it takes multiple tries. Took me 3 times.
The "MAX" series B450 motherboards do not require BIOS updates in order to support the third generation Ryzen CPUs.

-Wolf sends
 

yourilevoye

Commendable
Jan 6, 2017
203
7
1,715
20
The "MAX" series B450 motherboards do not require BIOS updates in order to support the third generation Ryzen CPUs.

-Wolf sends
Intresting, I was not aware of that.
Then the issue looks similair to what a friend of mine had, where the time of the PC staying on was lowering every day. He did a CPU RMA and after installing a new CPU, it was fine.
 

InvalidError

Titan
Moderator
Intresting, I was not aware of that.
Older non-MAX variants of MSI's motherboard have an SPI-flash chip too small to hold micro-code and related data for all AM4 CPUs without sacrificing something else such as fancy UI or compatibility with first-gen chips, so MSI launched the MAX line with a large enough chip to get there. That's the main if not only difference.

I wish more board manufacturers had a similarly clear way of telling old boards from factory-updated ones.
 
Nov 11, 2019
5
0
10
0
Have you checked the CPU for bent pins?
When you updated the BIOS, did you use the Beta Version (H51) or the latest stable release (H4)?
When you installed just a single RAM module, did you use RAM slot DIMMA2?
Did you test each RAM Module, individually, in that slot?
Details are everything. WHICH EVGA 650w power supply did you purchase/are using? Please include the model number.
Details are everything. WHICH Corsair Vengeance LPX DDR4-3000 RAM are you using? Please include the model number.

-Wolf sends
thank you for your answer!
i checked multiple times CPU's pins (even when i RMAed a motherboard i thought was the problem, a msi B450M gaming plus).
I tried every release and today, before updating to H51, i tried to turn it on again with H4 but it wasn't even able to boot one time, so i updated and the situation didn't change...
Yes i used DIMMA2.
Yes i tested both of them individually.
PSU i'm using it's EVGA SuperNOVA 650 G2 Gold 80+ model Number 220-G2-0650-Y2 .
RAM i'm using it's Corsair Vengeance ddr4 3000Mhz 2x8Gb c15 k2 model Number CMK16GX4M2B3000C15
thanks! :)
 
Nov 11, 2019
5
0
10
0
Try to find another motherboard to test the cpu.Rarely the problem comes from cpu. Every component seems ok and it should work. Also check if the cpu cooler is well conected and sits tight on the cpu.
thank you for your answer!
I forgot to mention (sorry) that previously i had a msi B450M Gaming plus which didn't work even if updated, so i changed it with this one, sure that i was solving the problem but i was wrong...
I checked the cooler, the CPU and every cable connection and it seems all as it should be... i'm not a super expert but this is my 4th pc i build from zero and i don't know how many parts i changed in other PCs for friends, so i'm starting to fear that ther's a serious problem or that i'm missing something really important (but i really can't figure it out what...)
thank you! :)
 

Wolfshadw

Titan
Moderator
thank you for your answer!
i checked multiple times CPU's pins (even when i RMAed a motherboard i thought was the problem, a msi B450M gaming plus).
I tried every release and today, before updating to H51, i tried to turn it on again with H4 but it wasn't even able to boot one time, so i updated and the situation didn't change...
Yes i used DIMMA2.
Yes i tested both of them individually.
PSU i'm using it's EVGA SuperNOVA 650 G2 Gold 80+ model Number 220-G2-0650-Y2 .
RAM i'm using it's Corsair Vengeance ddr4 3000Mhz 2x8Gb c15 k2 model Number CMK16GX4M2B3000C15
thanks! :)
Thanks

Memory QVL States:
CMK16GX4M2B3000C15 ver5.30
CMK16GX4M2B3000C15 ver3.32

Your RAM:
CMK16GX4M2B3000C15

I'd say it should be compatible.

Power supply appears to be very well rated, but even top-name models can fail. I wouldn't expect this to be the issue, but would it be possible to test the power supply in another similar system?

-Wolf sends
 
Nov 11, 2019
5
0
10
0
Thanks

Memory QVL States:
CMK16GX4M2B3000C15 ver5.30
CMK16GX4M2B3000C15 ver3.32

Your RAM:
CMK16GX4M2B3000C15

I'd say it should be compatible.

Power supply appears to be very well rated, but even top-name models can fail. I wouldn't expect this to be the issue, but would it be possible to test the power supply in another similar system?

-Wolf sends
Hi!
I have already used it with my older PC (I'm building this "new one" step by step for a matter of money) and I didn't have any problem at all!
It was: CPU Intel i7 3770
RAM DDR3 2x4 GB adata
GPU (same) gtx 1070ti
MB Asus CM6340
Thank you :)
 
Nov 11, 2019
5
0
10
0
Thanks

Memory QVL States:
CMK16GX4M2B3000C15 ver5.30
CMK16GX4M2B3000C15 ver3.32

Your RAM:
CMK16GX4M2B3000C15

I'd say it should be compatible.

Power supply appears to be very well rated, but even top-name models can fail. I wouldn't expect this to be the issue, but would it be possible to test the power supply in another similar system?

-Wolf sends
Hi!
So I tried with an old PSU (as I've been suggested by a friend who is an IT engineer) and, even if it has just 4 pins for the CPU, it all worked fine, I could update games on steam, update windows and also run prime95 for like 30-40minuts with no problem at all! Soooo I think I can say it's definitely a PSU problem (even if it's strange that it works with my older MB, CPU and RAM)
 

ASK THE COMMUNITY

TRENDING THREADS