Question Ryzen 5 issue with ASRock motherboard

Jul 17, 2019
4
0
10
0
I have a PC with ASRock B350 Pro4 motherboard, 16GB Corsair Vengeance RAM, Ryzen 3 2200G CPU & RX 580 GPU; this runs beautifully but I wanted to upgrade the CPU for SIM racing games. I tried a Ryzen 5 1600X & 2600X but neither sent anything to the video output. I tried swapping RAM slots, reseating the GPU, clearing CMOS...still the same. Pop the Ryen 3 2200G back in & boots up fine.
I'm using the GPU connections for video & have tried HDMI & DVI without success; the motherboard BIOS is correctly set to not use on board graphics & is at revision 5.10, which looks like it's more than current enough to run Ryzen 5 1st generation (2.1 or later) & 2nd generation Zen+ (4.7 or later) CPUs.
Anyone have a suggestion? I get a strange feeling I'm misssing something obvious but it just isn't coming to me.
Thanks!
 

boju

Champion
Sounds like you are using the 580's video ports but some parts in your paragraph has me still wondering if not. The mobo has hdmi and dvi and when you changed to a non apu cpu the video drops until the 2200g is returned. Nothing to me is making sense unless both 1600x/2600x are doa, unlikely.

Im pretty sure you would have noticed something was up with 580's performance if you were running the igpu instead.
 
Jul 17, 2019
4
0
10
0
Sounds like you are using the 580's video ports but some parts in your paragraph has me still wondering if not. The mobo has hdmi and dvi and when you changed to a non apu cpu the video drops until the 2200g is returned. Nothing to me would make sense unless both 1600x/2600x are doa, unlikely.

Im pretty sure you would have noticed something was up with 580's performance if you were running the igpu instead.
Thanks, definitely using the 580's ports & I tried my old 570 & my son's GTX 1070 with no different outcome.
Do I need to maybe just update the BIOS anyway? I thought about that but then saw a lot of posts, including from manufacturers, saying only update BOIS if there's a specific issue or requirement.
 

boju

Champion
Bios revision to run 2nd gen Ryzen shouldn't prevent the motherboard from running first gen 1600x nor 2600x. Don't know what's up with that.

Did you try reset cmos with either 1600x or 2600x with no gpu installed?
 

ASK THE COMMUNITY

TRENDING THREADS