Question Ryzen 5000 series gets stuck at 3.6GHz after computer wakes up from sleep ?

scappy

Reputable
Feb 2, 2017
13
0
4,510
0
Hi, I have a dual-boot system running Linux and Windows 10 and I have a minor issue with my windows OS. I normally just put my computer in sleep mode when I'm not using it. In Linux, everything works fine. But on windows I noticed every time I would turn my computer to sleep and wake it up, the CPU gets stuck at 3.6GHz -- it won't scale. Normally the CPU scale from 3.7 to 4.9Ghz but when waking up from sleep it's stuck at 3.6Ghz. I tried rendering in premier and blender to make sure and it just stays at 3.6GHz. I would need to fresh reboot my system to make the CPU scale again properly.

Specs:
Gigabyte X570 Aorus Elite
Ryzen 9 5900X
32GB of RAM.
Windows 10 Pro Version 21H1 build 19043.1288 on a 500GB SSD.
Linux on a separate 500GB SSD

Any insights will be greatly appreciated. Thank you!
 
Have you installed latest BIOS on your motherboard? and installed latest AMD chipset drivers? I'd let it run the Ryzen Power plan that the chipset drivers install with no changes.

Other than that, Windows sleep and hibernation has always been a hot mess for me, I more often than not disable it. Usually though it's because it won't restart at all after going to sleep with hibernation...not without a complete boot up.
 

scappy

Reputable
Feb 2, 2017
13
0
4,510
0
Yes, I do have the latest BIOS on my motherboard. I usually have a lot of programs running at the same time that's why I normally just turn my computer to Sleep mode so that I don't have to re-open each one of them when I get back. Sleep mode works the way it should. Only that minor thing with the CPU getting locked up at 3.6GHz, that's the only problem.
 
Yes, I do have the latest BIOS on my motherboard. I usually have a lot of programs running at the same time that's why I normally just turn my computer to Sleep mode so that I don't have to re-open each one of them when I get back. Sleep mode works the way it should. Only that minor thing with the CPU getting locked up at 3.6GHz, that's the only problem.
How is your BIOS set up? I'd set it up full-auto, with both clocks and VCore voltage settings. Also make sure Advanced C States are enabled and CPPC and CPPC Preferred Cores enabled too; it should be by default but it doesn't hurt to check.

Not much help but it may be an unfavorable interaction with Window's sleep/resume mechanism and the dual boot you're running. Is there any way you can test without it?
 

scappy

Reputable
Feb 2, 2017
13
0
4,510
0
Right now I'm actually thinking there's really might be some settings in the BIOS that's causing this that only affects windows 10 and not Linux. Yesterday I reinstalled windows and it's the same thing. One of the weird things is, after waking up from sleep mode, I would run Cinebench and all cores are stuck at 3.69GHz. Then right after Cinebench finished, all cores goes a tad higher at 3.74GHz.

So basically, I get the lowest core clock when running Cinebench whenever my computer goes back from sleep mode.

EDIT: Yes, C State, CPPC, CPPC Preferred Cores are all Enabled in the BIOS.
 
Last edited:

scappy

Reputable
Feb 2, 2017
13
0
4,510
0
After trying so hard to figure out how to fix the sleep mode issue with the CPU clock speed, I've decided to just give it up and just use hibernate.
It's a bit tedious since I'm on a dual-boot machine but it works.
 

ASK THE COMMUNITY