Question Ryzen 5900x doesn't boot

Jun 13, 2021
44
1
35
0
Hi,

I have an Asus ws x570 motherboard wich I used with my 3900x now I have upgraded to an 5900x and It doesn't boot anymore.

The dram led Is Forever on with fan spinning.

Should I reset the BIOS? Could be an xmp issue?
 

Ralston18

Titan
Moderator
Source of the 5900X ?

Any beep codes or lit LED's?

Update your post to include full system hardware specs and OS information.

PSU: make, model, wattage, age, condition?

Try reseating all connectors, cards, RAM, and jumpers to ensure that all are fully and firmly in place.
 
Jun 13, 2021
44
1
35
0
Source of the 5900X ?

Any beep codes or lit LED's?

Update your post to include full system hardware specs and OS information.

PSU: make, model, wattage, age, condition?

Try reseating all connectors, cards, RAM, and jumpers to ensure that all are fully and firmly in place.

I reseated the old 3900x and It works fine.

3rd vendor but shipped from Amazon
PSU its and evga 850W G3 1yr old the only led that come up its the dram and int znv
 
Jun 13, 2021
44
1
35
0
That chip is only supported with BIOS 2311 or newer. And yes you should reset the BIOS when upgrading CPUs.
That chip is only supported with BIOS 2311 or newer. And yes you should reset the BIOS when upgrading CPUs.
Update BIOS, First boot VGa and Boot led were stuck, then I shutted the PC off, booted again normally into Windows and now seems to work fine.
Why this happened?
 

Ralston18

Titan
Moderator
Jun 13, 2021
44
1
35
0
@dorsai

Reference: "That chip is only supported with BIOS 2311 or newer "

Source?

I was looking at 2802 per the following link:

https://www.windowscentral.com/how-check-if-you-have-latest-motherboard-bios-amd-ryzen-5000-cpus

2311 for "Crosshair/Strix" as I understood the requirements.

No disagreement - just compelled to ask when things do not seem to match up. Thanks.

May be moot as appears to be "overtaken by events".

@NiaD - just for the record, what BIOS is now in place?
3k something
I had 1300 I think
 
Jun 13, 2021
44
1
35
0
@dorsai

Reference: "That chip is only supported with BIOS 2311 or newer "

Source?

I was looking at 2802 per the following link:

https://www.windowscentral.com/how-check-if-you-have-latest-motherboard-bios-amd-ryzen-5000-cpus

2311 for "Crosshair/Strix" as I understood the requirements.

No disagreement - just compelled to ask when things do not seem to match up. Thanks.

May be moot as appears to be "overtaken by events".

@NiaD - just for the record, what BIOS is now in place?
Also why my clock Speed Is stuck at 3.6GHz in ryzen master?
 

dorsai

Distinguished
@dorsai

Reference: "That chip is only supported with BIOS 2311 or newer "

Source?

I was looking at 2802 per the following link:

https://www.windowscentral.com/how-check-if-you-have-latest-motherboard-bios-amd-ryzen-5000-cpus

2311 for "Crosshair/Strix" as I understood the requirements.

No disagreement - just compelled to ask when things do not seem to match up. Thanks.

May be moot as appears to be "overtaken by events".

@NiaD - just for the record, what BIOS is now in place?

Motherboard website:
 

COLGeek

Cybernaut
Moderator
Hi,

I have an Asus ws x570 motherboard wich I used with my 3900x now I have upgraded to an 5900x and It doesn't boot anymore.

The dram led Is Forever on with fan spinning.

Should I reset the BIOS? Could be an xmp issue?
Put the 3900X back into the system and update the motherboard BIOS to the latest version, then install the 5900X.

First, determine the BIOS version you have. Note that there are versions with notes about performing chipset driver updates prior to installing. Take this into account.


Or, you could likely skip to the new version if you plan to fully (clean) install Windows after changing to the 5900X.

Good motherboard by the way.
 
Jun 13, 2021
44
1
35
0
Put the 3900X back into the system and update the motherboard BIOS to the latest version, then install the 5900X.

First, determine the BIOS version you have. Note that there are versions with notes about performing chipset driver updates prior to installing. Take this into account.


Or, you could likely skip to the new version if you plan to fully (clean) install Windows after changing to the 5900X.

Good motherboard by the way.
Hi, I updated all the drivers and BIOS now It works fine, also, It runs cooler than the 3900x

But I have two questions,

When doing prime95 the max clock Speed was 3.5GHz , shouldn't be 4.6?
When I First Power It on (the time It posted) I got the GPU light on the mobo, then I shutted the PC down from the Wall and was a piece of cake, why this happened?

Thanks by the way
 

ASK THE COMMUNITY

TRENDING THREADS