[SOLVED] Ryzen 5900x randomly crashing

dhruvky94

Reputable
Feb 1, 2017
55
2
4,545
1
Hi,

I recently build a new system:
CPU: Ryzen 5900X (Stock)

Cooler: NZXT X63

Ram: GSkill Tidentz NEO 3600MHZ

SSD: Samsung 1 TB EVO PLUS

GPU: RTX 3090 FE (Installed in PCIE first slot with Gen 4)

Motherboard: Asus Crosshair VIII Hero X570 (Bios: 2311,
I have tried will all the new BIOS and this one is the most stable till now)

PSU: Corsair RM1000X

Case: NZXT H710

Now, I am facing random restarts when I am using the RAM's DOCP profile. Is my RAM defective?
Most of the shutdowns happen when 3dmark is done running the stress test and tries to validate the results or I am uninstalling something.
The error is:

Source: WHEA-LOGGER
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error

I am not overclocking or anything, just using the default DOCP profile. I have tried all the BIOS versions from 2311 onwards, but all of them have me crashing in DOCP. Can anyone please help here?
 
Umm sorry, I am a novice when it comes to RAM overclocking/manual adjustment. Should I just change the manual setting in the Speed to 3200MHZ from 3600MHZ and leave everything else to default?
Yes. Literally change the speed down, leave everything else at auto, or at default DOCP.

It's a little unusual that changing the power plan, would prevent a hardware issue from occurring. But possible I guess.

Typically for Ryzen you should use the Ryzen balanced power plan. You can get that here : AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops

I suspect that's what your using if your chipset driver is up to date, you will see the balanced plan in power options.

If it works, that's a result. Good job :)
 

dhruvky94

Reputable
Feb 1, 2017
55
2
4,545
1
Hey there,

You can try set the ram timings/voltage etc manually in the bios, rather than DOCP. See if that makes it more stable.
I actually changed my power plan from High performance to Balanced and it seems more stable right now, not sure. Can that affect anything?
 

dhruvky94

Reputable
Feb 1, 2017
55
2
4,545
1
I don't think your ram is defective but that it is a different memory controller. Try setting the ram speed to 3200Mhz in the bios to see if it improves stability.
Umm sorry, I am a novice when it comes to RAM overclocking/manual adjustment. Should I just change the manual setting in the Speed to 3200MHZ from 3600MHZ and leave everything else to default?
 

dhruvky94

Reputable
Feb 1, 2017
55
2
4,545
1
Just an update everyone, I just changed my power settings to Balanced and it doesn't crash anymore. Is it the recommended Setting for Ryzen? Never used Ryzen before so no clue.
 
Umm sorry, I am a novice when it comes to RAM overclocking/manual adjustment. Should I just change the manual setting in the Speed to 3200MHZ from 3600MHZ and leave everything else to default?
Yes. Literally change the speed down, leave everything else at auto, or at default DOCP.

It's a little unusual that changing the power plan, would prevent a hardware issue from occurring. But possible I guess.

Typically for Ryzen you should use the Ryzen balanced power plan. You can get that here : AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops

I suspect that's what your using if your chipset driver is up to date, you will see the balanced plan in power options.

If it works, that's a result. Good job :)
 

dhruvky94

Reputable
Feb 1, 2017
55
2
4,545
1
Yes. Literally change the speed down, leave everything else at auto, or at default DOCP.

It's a little unusual that changing the power plan, would prevent a hardware issue from occurring. But possible I guess.

Typically for Ryzen you should use the Ryzen balanced power plan. You can get that here : AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops

I suspect that's what your using if your chipset driver is up to date, you will see the balanced plan in power options.

If it works, that's a result. Good job :)
Thank you :)

I think for Ryzen 5000 series, there isn't any special Ryzen power mode as I do have the latest chipset drivers installed. I was also reading on AMD forums to use Windows balanced mode for default AMD and High performance for better control.
 

dhruvky94

Reputable
Feb 1, 2017
55
2
4,545
1
Yes. Literally change the speed down, leave everything else at auto, or at default DOCP.

It's a little unusual that changing the power plan, would prevent a hardware issue from occurring. But possible I guess.

Typically for Ryzen you should use the Ryzen balanced power plan. You can get that here : AMD Drivers and Support for Radeon, Radeon Pro, FirePro, APU, CPU, Ryzen, desktops, laptops

I suspect that's what your using if your chipset driver is up to date, you will see the balanced plan in power options.

If it works, that's a result. Good job :)
An update here, I just installed the AMD chipset drivers and the system immediately started crashing even in balanced plan. Uninstalled it and it stabilised. Changed power plan again and the system started crashing a lot!
 

ASK THE COMMUNITY

TRENDING THREADS