Question Ryzen 7 3700x all core clocks at 3Ghz

Eyro316

Prominent
May 3, 2020
12
1
515
0
Hello, I just tried some benchmarking and I just found out that my CPU isnt going full throttle and it's just sitting at 80-90% usage with 3Ghz clock speed on all cores while using CINEBENCH R20, is there a problem to it?
PC Specs:
Ryzen 7 3700x
B450M Mortar Max
16Gb 3200mhz Dual Channel Ram
gtx1070
CM MWE 230V 550W

Picture was taken while CINEBENCH R20 is running
 
Hello, I just tried some benchmarking and I just found out that my CPU isnt going full throttle and it's just sitting at 80-90% usage with 3Ghz clock speed on all cores while using CINEBENCH R20, is there a problem to it?
PC Specs:
Ryzen 7 3700x
B450M Mortar Max
16Gb 3200mhz Dual Channel Ram
gtx1070
CM MWE 230V 550W

Picture was taken while CINEBENCH R20 is running
Check BIOS for Boost and PBO settings.
Also check your Power Plan and see if Maximum processor setting is 100%.
 
Hello, I just tried some benchmarking and I just found out that my CPU isnt going full throttle and it's just sitting at 80-90% usage with 3Ghz clock speed on all cores while using CINEBENCH R20, is there a problem to it?
PC Specs:
Ryzen 7 3700x
B450M Mortar Max
16Gb 3200mhz Dual Channel Ram
gtx1070
CM MWE 230V 550W

Picture was taken while CINEBENCH R20 is running
Looking at utilization can be a bit misleading if you're wondering about performance. Best thing is to just run the benchmark and compare to what 3700X's normally do. Utilization is really not well understood, especially for a dynamic CPU like Ryzen.

I have a 3700X running under a tweaked PBO and it scores from 5100-5150 multi-threaded, 510 single thread. If I run a simple PBO it will be about 5025-5050, no PBO at all about 4900 and around 494 single thread.

When running CB for a benchmark have nothing else running. Also do a reboot and let the system settle down for about a minute before running it.
 

Eyro316

Prominent
May 3, 2020
12
1
515
0
nevermind, I have fixed the problem, I bought a new PSU, 750W Gold Rated, it fixed it, I was now at 3.9-4ghz while running CINEBENCH R20
 
Reactions: kurdtnz

ASK THE COMMUNITY